diff mbox series

bug#69389: [PATCH v2] gnu: Add python-xmp-toolkit.

Message ID 87a5iewxqd.fsf@gnu.org
State New
Headers show
Series bug#69389: [PATCH v2] gnu: Add python-xmp-toolkit. | expand

Commit Message

Ludovic Courtès July 18, 2024, 3:01 p.m. UTC
Hi Felix,

Felix Gruber <felgru@posteo.net> skribis:

> * gnu/packages/python-xyz.scm (python-xmp-toolkit): New variable.
> * gnu/packages/patches/python-xmp-toolkit-add-missing-error-codes.patch:
> New file.
> * gnu/local.mk (dist_patch_DATA): Add it.
>
> Change-Id: Ibce05155961eb5ba199754646e08acff2410f95d

Applied with the changes below: I took the liberty to strip the
description of authorship info since that’s not something we usually do.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 17b4c982c1..fcf01f3d04 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -37518,11 +37518,11 @@  (define-public python-xmp-toolkit
     (arguments
      (list
       #:test-flags
-      '(list "-k" (string-append "not test_can_put_xmp and "
-                                 "not test_exempi_bad_combinations and "
-                                 "not test_formats and "
-                                 "not test_get_xmp and "
-                                 "not test_open_file_with_options"))
+      #~(list "-k" (string-append "not test_can_put_xmp and "
+                                  "not test_exempi_bad_combinations and "
+                                  "not test_formats and "
+                                  "not test_get_xmp and "
+                                  "not test_open_file_with_options"))
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'build 'configure-environment
@@ -37541,14 +37541,7 @@  (define-public python-xmp-toolkit
 
 Python XMP Toolkit is wrapping Exempi (using ctypes), a C/C++ XMP library
 based on Adobe XMP Toolkit, ensuring that future updates to the XMP standard
-are easily incorporated into the library with a minimum amount of work.
-
-Python XMP Toolkit has been developed by:
-@itemize
-@item ESA/Hubble - European Space Agency
-@item ESO - European Southern Observatory
-@item CRS4 - Centre for Advanced Studies, Research and Development in Sardinia
-@end itemize")
+are easily incorporated into the library with a minimum amount of work.")
       (license license:bsd-3)))
 
 ;;;