[bug#74329,v3,5/8] gnu: Replace quotations with texinfo markup in Emacs packages.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-xah-fly-keys, emacs-ob-asymptote,
emacs-swiper, emacs-pyvenv, emacs-envrc, emacs-kind-icon, emacs-vcsh,
emacs-org-web-tools, emacs-org-drill-table, emacs-nhexl-mode): Fix
description.
Change-Id: I8ef605cf1ad6556713a90dbb657eb02feaa87676
---
gnu/packages/emacs-xyz.scm | 46 ++++++++++++++++++++------------------
1 file changed, 24 insertions(+), 22 deletions(-)
@@ -3417,9 +3417,10 @@ (define-public emacs-xah-fly-keys
(home-page "http://xahlee.info/emacs/misc/ergoemacs_vi_mode.html")
(synopsis "Modal keybinding system for Emacs, based on command frequency and
ergonomics")
- (description "xah-fly-keys.el is a modal editing mode for Emacs, like Vi,
-but the design of key/command choice is based on command frequency statistics
-and ease-of-key score. Most frequently used commands have most easy keys.")
+ (description "@emph{xah-fly-keys.el} is a modal editing mode for Emacs,
+like Vi, but the design of key/command choice is based on command frequency
+statistics and ease-of-key score. Most frequently used commands have most
+easy keys.")
(license license:gpl3))))
(define-public emacs-xr
@@ -9833,7 +9834,7 @@ (define-public emacs-ob-asymptote
"This package provides Org Babel support for evaluating Asymptote source
code. This differs from most standard languages in that:
@itemize
-@item there is no such thing as a ``session'' in Asymptote,
+@item there is no such thing as a @emph{session} in Asymptote,
@item we are generally only going to return results of type @code{file},
@item we are adding the @code{file} and @code{cmdline} header arguments, if
file is omitted then the @samp{-V} option is passed to the @command{asy}
@@ -14209,8 +14210,8 @@ (define-public emacs-swiper
The search regex can be split into groups with a space. Each group is
highlighted with a different face.
-It can double as a quick `regex-builder', although only single lines will be
-matched.")
+It can double as a quick @emph{regex-builder}, although only single lines will
+be matched.")
(license license:gpl3+)))
(define-public emacs-ivy-xref
@@ -15821,7 +15822,7 @@ (define-public emacs-el-x
#t)))))
(home-page "https://github.com/sigma/el-x")
(synopsis "Emacs Lisp extensions")
- (description "command@{emacs-el-x} defines the @code{dflet} macro to
+ (description "@command{emacs-el-x} defines the @code{dflet} macro to
provide the historic behavior of @code{flet}, as well as
@code{declare-function} stub for older Emacs.")
(license license:gpl2+)))
@@ -16045,8 +16046,8 @@ (define-public emacs-pyvenv
(list emacs-ert-runner emacs-mocker))
(home-page "https://github.com/jorgenschaefer/pyvenv")
(synopsis "Python virtual environment interface for Emacs")
- (description "pyvenv.el is a minor mode to support using Python virtual
-environments (virtualenv) inside Emacs.")
+ (description "@emph{pyvenv.el} is a minor mode to support using Python
+virtual environments (virtualenv) inside Emacs.")
(license license:gpl3+)))
(define-public emacs-highlight-indent-guides
@@ -22740,10 +22741,10 @@ (define-public emacs-envrc
(description
"This is library which uses Direnv to set environment variables on
a per-buffer basis. This means that when you work across multiple projects
-which have @file{.envrc} files, all processes launched from the buffers ``in''
-those projects will be executed with the environment variables specified in
-those files. This allows different versions of linters and other tools to be
-used in each project if desired.")
+which have @file{.envrc} files, all processes launched from the buffers
+@emph{in} those projects will be executed with the environment variables
+specified in those files. This allows different versions of linters and other
+tools to be used in each project if desired.")
(license license:gpl3+)))
(define-public emacs-prop-menu
@@ -26285,7 +26286,7 @@ (define-public emacs-kind-icon
(home-page "https://github.com/jdtsmith/kind-icon")
(synopsis "Completion kind icons in Emacs")
(description "Kind-icon mode adds a colorful icon or text prefix based on
-@code{:company-kind} for compatible completion UIs. The ``kind'' prefix is
+@code{:company-kind} for compatible completion UIs. The @code{kind} prefix is
typically used for differentiating completion candidates such as variables or
functions.")
(license license:gpl3+)))
@@ -27287,7 +27288,7 @@ (define-public emacs-vcsh
(home-page "https://gitlab.com/stepnem/vcsh-el")
(synopsis "Emacs VCSH integration")
(description
- "This library provides basic ``enter'' functionality and a few
+ "This library provides basic @code{enter} functionality and a few
convenience commands to initialize a @acronym{VCSH, Version Control System for
$HOME} repository and add files to it. It can be used in conjunction with
Magit.")
@@ -30634,7 +30635,7 @@ (define-public emacs-org-web-tools
for retrieving web page content and processing it into Org mode content.
For example, you can copy a URL to the clipboard or kill-ring, then run
-a command that downloads the page, isolates the ``readable'' content with
+a command that downloads the page, isolates the @emph{readable} content with
@command{eww-readable}, converts it to Org mode content with Pandoc, and
displays it in an Org mode buffer. Another command does all of that but
inserts it as an Org entry instead of displaying it in a new buffer.")
@@ -34256,7 +34257,7 @@ (define-public emacs-org-drill-table
(synopsis "Generate Org drill cards using Org mode tables")
(description
"This package generates drill cards based on an Org mode table in the
-current subtree. The cards are inserted under a new ``Cards'' heading in the
+current subtree. The cards are inserted under a new @emph{Cards} heading in the
current tree.")
(license license:gpl3+))))
@@ -35023,18 +35024,19 @@ (define-public emacs-nhexl-mode
This minor mode implements similar functionality to @command{hexl-mode},
but using a different implementation technique, which makes it
-usable as a \"plain\" minor mode. It works on any buffer, and does
+usable as a @emph{plain} minor mode. It works on any buffer, and does
not mess with the undo log or with the major mode.
It also comes with:
@itemize
-@item @command{nhexl-nibble-edit-mode}: a \"nibble editor\" minor mode, where
-the cursor pretends to advance by nibbles (4-bit) and the self-insertion keys
-(which only work for hex-digits) will only modify the nibble under point.
+@item @command{nhexl-nibble-edit-mode}: a @emph{nibble editor} minor mode,
+where the cursor pretends to advance by nibbles (4-bit) and the self-insertion
+keys (which only work for hex-digits) will only modify the nibble under point.
@item @command{nhexl-overwrite-only-mode}: a minor mode to try and avoid
moving text. In this minor mode, not only self-inserting keys overwrite
-existing text, but commands like `yank' and @command{kill-region} as well.
+existing text, but commands like @command{yank} and @command{kill-region} as
+well.
@item It overrides @code{C-u} to use hexadecimal, so you can do @code{C-u a 4
C-f} to advance by #xa4 characters.
@end itemize")