bug#33764: [PATCH] gnu: z3: Update to 4.8.3 and add python{, 2}-z3 bindings.

Message ID 878t0gi1vc.fsf@gnu.org
State Accepted
Headers show
Series bug#33764: [PATCH] gnu: z3: Update to 4.8.3 and add python{, 2}-z3 bindings. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès Dec. 23, 2018, 5:33 p.m. UTC
Hi Amin,

Amin Bandali <bandali@gnu.org> skribis:

> From ad9433c11ebba672db3ca75689ebee92ea9da7de Mon Sep 17 00:00:00 2001
> From: Amin Bandali <bandali@gnu.org>
> Date: Sat, 22 Dec 2018 10:16:57 -0500
> Subject: [PATCH v3] gnu: z3: Update to 4.8.3 and provide python3 bindings
>
> * gnu/packages/maths.scm (z3): Update to 4.8.3.
> [build-system]: Switch from cmake to make, and use the current
> scripts/mk_make.py build script instead of the now-deprecated
> contrib/cmake/bootstrap.py.

Applied with the fixes below for ‘which’.

Thank you!

Ludo’.

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1b6127e9f7..448d9e373b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -54,7 +54,7 @@ 
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix utils)
-  #:use-module (guix build utils)
+  #:use-module ((guix build utils) #:select (alist-replace))
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system ocaml)
@@ -64,6 +64,7 @@ 
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
@@ -117,7 +118,6 @@ 
   #:use-module (gnu packages tex)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages version-control)
-  #:use-module (gnu packages which)
   #:use-module (gnu packages wxwidgets)
   #:use-module (gnu packages xml)
   #:use-module (srfi srfi-1))