[bug#34364] Add package: Emacs-shroud; Emacs interface for shroud

Message ID 878sysotda.fsf@disroot.org
State Accepted
Headers show
Series [bug#34364] Add package: Emacs-shroud; Emacs interface for shroud | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Amar M. Singh Feb. 7, 2019, 9:11 a.m. UTC
This is not a polished software by any means.
This is an interface for the shroud password manager
https://dthompson.us/projects/shroud.html

Patch:

From b7f9ec3820158d2b6fdde64dfed0fa7233ec5951 Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Thu, 7 Feb 2019 14:37:25 +0530
Subject: [PATCH] add emacs-shroud; emacs interface for shroud

Signed-off-by: Amar Singh <nly@disroot.org>
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Marius Bakke Jan. 27, 2020, 10:13 p.m. UTC | #1
This was pushed in a38525789cdb6b4baa440cdf9f265085d4378ec5.

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 960518f9d..d43153b55 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8518,6 +8518,28 @@  close, copy, cut, paste, undo, redo.")
 standard Unix password manager\").")
     (license license:gpl2+)))
 
+(define-public emacs-shroud
+  (package
+   (name "emacs-shroud")
+   (version "0.1")
+   (source (origin
+            (method url-fetch)
+            (uri
+             (string-append "https://github.com/o-nly/" name "/archive/release-" version ".tar.gz"))
+            (sha256
+             (base32
+              "0jxfa2fa6r0ay9c6nf4xwz5vddb1v45cgaxkgdxxhck0l527i3yc"))))
+   (build-system emacs-build-system)
+   (propagated-inputs
+    `(("emacs-f" ,emacs-f)
+      ("emacs-s" ,emacs-s)
+      ("shroud" ,shroud)))
+   (home-page "http://nly.info.tm:9001/emacs/shroud.el")
+   (synopsis "Shroud (gpg) support for Emacs")
+   (description
+    "This package provides functions for working with shroud password manager.")
+   (license license:gpl3+)))
+
 (define-public emacs-pass
   (package
     (name "emacs-pass")