bug#34380: [PATCH 2/5] gnu: Add python-language-server.

Message ID 878sykhdcw.fsf@gnu.org
State Accepted
Headers show
Series bug#34380: [PATCH 2/5] gnu: Add python-language-server. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès Feb. 12, 2019, 10:05 p.m. UTC
Brett Gilio <brettg@posteo.net> skribis:

>>From 915bd232185ebcab96d96dc400ee3f010e691048 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Thu, 7 Feb 2019 22:03:42 -0600
> Subject: [PATCH 2/5] gnu: Add python-language-server.
>
> * gnu/packages/python-xyz.scm (python-language-server): New variable.

Applied with the changes below, thanks!

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e8ff525c7e..4218515961 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2592,7 +2592,7 @@  Language (TOML) configuration files.")
   (build-system python-build-system)
   (propagated-inputs
    `(("python-pluggy" ,python-pluggy)
-     ("python-jsonrps-server" ,python-jsonrpc-server)
+     ("python-jsonrpc-server" ,python-jsonrpc-server)
      ("python-jedi" ,python-jedi)
      ("python-yapf" ,python-yapf)
      ("python-pyflakes" ,python-pyflakes)
@@ -2601,12 +2601,13 @@  Language (TOML) configuration files.")
      ("python-mccabe" ,python-mccabe)
      ("python-rope" ,python-rope)
      ("python-autopep8" ,python-autopep8)))
-  (home-page
-    "https://github.com/palantir/python-language-server")
-  (synopsis
-    "Python Language Server for the Language Server Protocol")
+  (home-page "https://github.com/palantir/python-language-server")
+  (synopsis "Python implementation of the Language Server Protocol")
   (description
-    "The Python Language Server (pyls) is an implementation of the Python 3 language specification for the LSP. This tool is used in many text-editing environments to provide a complete and integrated feature-set for programming Python effectively.")
+   "The Python Language Server (pyls) is an implementation of the Python 3
+language specification for the Language Server Protocol (LSP).  This tool is
+used in text editing environments to provide a complete and integrated
+feature-set for programming Python effectively.")
   (license license:expat)))
 
 (define-public python-black