[bug#35185] gnu: mu: Update to 1.2.

Message ID 878swl7bk1.fsf@gmx.com
State Accepted
Headers show
Series [bug#35185] gnu: mu: Update to 1.2. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Pierre Langlois April 7, 2019, 9:25 p.m. UTC
Hello Guix!

Here's an update for mu!

I've noticed we've moved away from using Github's generated tarballs and
using git-fetch instead. However, it looks like the tarball for mu is
provided by the developer so we should be fine.

Is that right?  See "Assets" from https://github.com/djcb/mu/releases/tag/1.2 .

Thanks,
Pierre

Comments

Tobias Geerinckx-Rice April 7, 2019, 10:12 p.m. UTC | #1
Pierre,

Upstream wrote:
> Substantial (algorithmic) speed-up of message-threading

\o/

Pierre Langlois wrote:
> I've noticed we've moved away from using Github's generated 
> tarballs and
> using git-fetch instead. However, it looks like the tarball for 
> mu is
> provided by the developer so we should be fine.
>
> Is that right?

Yes.  These unreliable (auto)-‘generated tarballs’ we're getting 
rid of have ‘/archive/’ in the URL.  Others are fine.

> +                                  "download/" version "/mu-" 
> version
> +                                  ".0.tar.xz"))

I've added the ‘.0’ to VERSION instead, and will push this 
tomorrow after some testing.

Thanks!

T G-R
Pierre Langlois April 7, 2019, 10:23 p.m. UTC | #2
Hi Tobias,

Tobias Geerinckx-Rice writes:

> Pierre,
>
> Upstream wrote:
>> Substantial (algorithmic) speed-up of message-threading
>
> \o/

Yes! Full disclaimer, I've been running a git snapshot of mu for the
past few months just so I could get this early :-).

>
> Pierre Langlois wrote:
>> I've noticed we've moved away from using Github's generated tarballs
>> and
>> using git-fetch instead. However, it looks like the tarball for mu
>> is
>> provided by the developer so we should be fine.
>>
>> Is that right?
>
> Yes.  These unreliable (auto)-‘generated tarballs’ we're getting rid
> of have ‘/archive/’ in the URL.  Others are fine.
>
>> +                                  "download/" version "/mu-" 
>> version
>> +                                  ".0.tar.xz"))
>
> I've added the ‘.0’ to VERSION instead, and will push this tomorrow
> after some testing.
>
> Thanks!

Yeah, I wasn't sure what to make of the extra ".0" since the tagged
release is only "1.2". I think adding it to VERSION has you've done it
better.

Thanks!
Pierre
Tobias Geerinckx-Rice April 8, 2019, 10:44 a.m. UTC | #3
Tobias Geerinckx-Rice wrote:
> I've added the ‘.0’ to VERSION instead, and will push this 
> tomorrow
> after some testing.

Done as 857fabcd0b29a41c4a1263686254de648cfefc59.

Kind regards,

T G-R

Patch

From ba14d33b390c39da0f41067c4d6333808e5e584e Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Sun, 7 Apr 2019 22:16:00 +0100
Subject: [PATCH] gnu: mu: Update to 1.2.

* gnu/packages/mail.scm (mu): Update to 1.2.
[inputs]: Use gmime 3.
---
 gnu/packages/mail.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a2971a5e67..5ff5163fe1 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -24,7 +24,7 @@ 
 ;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017, 2018 Rene Saavedra <pacoon@protonmail.com>
-;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
@@ -675,15 +675,15 @@  security functionality including PGP, S/MIME, SSH, and SSL.")
 (define-public mu
   (package
     (name "mu")
-    (version "1.0")
+    (version "1.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/djcb/mu/releases/"
-                                  "download/v" version "/mu-"
-                                  version ".tar.xz"))
+                                  "download/" version "/mu-" version
+                                  ".0.tar.xz"))
               (sha256
                (base32
-                "04x5azl19gszw2h7argq666gf9xs4hy9q7w9cbqxvy08n56xqsln"))))
+                "0fh5bxvhjqv1p9z783lym8y1k3p4jcc3wg6wf7zl8s6w8krcfd7n"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -695,7 +695,7 @@  security functionality including PGP, S/MIME, SSH, and SSL.")
      `(("xapian" ,xapian)
        ("guile" ,guile-2.2)
        ("glib" ,glib)
-       ("gmime" ,gmime-2.6)))
+       ("gmime" ,gmime)))
     (arguments
      `(#:modules ((guix build gnu-build-system)
                   (guix build utils)
-- 
2.21.0