diff mbox series

[bug#37581] gnu: Add ruby-wayback-machine-downloader.

Message ID 878sq3wi04.fsf@GlaDOS.home
State Accepted
Headers show
Series [bug#37581] gnu: Add ruby-wayback-machine-downloader. | expand

Commit Message

Diego Nicola Barbato Oct. 2, 2019, 10:37 a.m. UTC
Hello Guix,

The following patch adds a Ruby program for downloading archived
websites from archive.org.  The gem contains no tests and while there
are tests on the github repository, those do require network access.
That's why I left the source as returned by the importer.

Regards,

Diego

Comments

Ludovic Courtès Oct. 25, 2019, 10:35 a.m. UTC | #1
Hi Diego,

Diego Nicola Barbato <dnbarbato@posteo.de> skribis:

> The following patch adds a Ruby program for downloading archived
> websites from archive.org.  The gem contains no tests and while there
> are tests on the github repository, those do require network access.
> That's why I left the source as returned by the importer.

OK.

>>From 1f28318ef8e7c11ff15f09778420567b7dc80e49 Mon Sep 17 00:00:00 2001
> From: Diego Nicola Barbato <dnbarbato@posteo.de>
> Date: Tue, 1 Oct 2019 16:06:57 +0200
> Subject: [PATCH] gnu: Add ruby-wayback-machine-downloader.
>
> * gnu/packages/ruby.scm (ruby-wayback-machine-downloader): New variable.

Applied.  Thank you, and sorry for the delay!

Ludo’.
diff mbox series

Patch

From 1f28318ef8e7c11ff15f09778420567b7dc80e49 Mon Sep 17 00:00:00 2001
From: Diego Nicola Barbato <dnbarbato@posteo.de>
Date: Tue, 1 Oct 2019 16:06:57 +0200
Subject: [PATCH] gnu: Add ruby-wayback-machine-downloader.

* gnu/packages/ruby.scm (ruby-wayback-machine-downloader): New variable.
---
 gnu/packages/ruby.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a886a1cdd2..86143277b1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
 ;;; Copyright © 2019 Collin J. Doering <collin@rekahsoft.ca>
+;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8954,3 +8955,29 @@  programming: intellisense, diagnostics, inline documentation, and type
 checking.")
     (home-page "https://solargraph.org/")
     (license license:expat)))
+
+(define-public ruby-wayback-machine-downloader
+  (package
+    (name "ruby-wayback-machine-downloader")
+    (version "2.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri
+             "wayback_machine_downloader"
+             version))
+       (sha256
+        (base32
+         "12kb1qmvmmsaihqab1prn6cmynkn6cgb4vf41mgv22wkcgv5wgk2"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:tests? #f)) ; no tests
+    (synopsis "Download archived websites from the Wayback Machine")
+    (description
+     "Wayback Machine Downloader is a command line tool for downloading
+websites from the Internet Archive's Wayback Machine (archive.org).
+It allows fine grained control over what to download by specifying
+which snapshots to consider and what files to include.")
+    (home-page
+     "https://github.com/hartator/wayback-machine-downloader")
+    (license license:expat)))
-- 
2.23.0