diff mbox series

[bug#38869] gnu: Add emacs-monky.

Message ID 878smqz4g4.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#38869] gnu: Add emacs-monky. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

LaFreniere, Joseph Jan. 2, 2020, 7:46 a.m. UTC
Patch file is attached.

--
Joseph LaFreniere

Comments

Ludovic Courtès Jan. 9, 2020, 10:22 p.m. UTC | #1
Hi,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> skribis:

>>From 675fbf18c7e3306fba978de7d1505d5a3057cd30 Mon Sep 17 00:00:00 2001
> From: Joseph LaFreniere <joseph@lafreniere.xyz>
> Date: Thu, 2 Jan 2020 01:43:21 -0600
> Subject: [PATCH] gnu: Add emacs-monky.
>
> * gnu/packages/emacs-xyz.scm (emacs-monky): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 675fbf18c7e3306fba978de7d1505d5a3057cd30 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Thu, 2 Jan 2020 01:43:21 -0600
Subject: [PATCH] gnu: Add emacs-monky.

* gnu/packages/emacs-xyz.scm (emacs-monky): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 125acfdf16..4b2f73bee4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7935,6 +7935,32 @@  pasting into and from @code{tmux} paste buffers.")
 to search.")
       (license license:gpl3+))))
 
+(define-public emacs-monky
+  (package
+    (name "emacs-monky")
+    (version "0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ananthakumaran/monky.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1fgn7al4zwz2k5wb5dy3byqg9lsrjk9fra341mxh5ma2pfwxjgps"))))
+    (build-system emacs-build-system)
+    (home-page "https://ananthakumaran.in/monky/index.html")
+    (arguments
+     `(#:tests? #t
+       #:test-command '("emacs" "--batch"
+                        "-l" "test/monky-unit-test.el"
+                        "-f" "ert-run-tests-batch-and-exit")))
+    (synopsis "Interactive interface for the Mercurial version control system")
+    (description
+     "Monky provides an Emacs interface for Mercurial (Hg).  Using Monky, you
+can selectively commit files, view the diffs, and other things.")
+    (license license:gpl3+)))
+
 (define-public emacs-monroe
   (package
     (name "emacs-monroe")
-- 
2.24.1