diff mbox series

[bug#38965,11/12] gnu: coq-interval: Update to 3.4.1.

Message ID 878smlvviw.fsf@gnu.org
State Accepted
Headers show
Series [bug#38965,01/12] gnu: Add ocaml-cairo2. | expand

Commit Message

Brett Gilio Jan. 6, 2020, 8:28 a.m. UTC

diff mbox series

Patch

From a846a0ecb584c8f76e366db33a720ab68f6df0d7 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@gnu.org>
Date: Mon, 6 Jan 2020 02:19:57 -0600
Subject: [PATCH 11/12] gnu: coq-interval: Update to 3.4.1.
To: guix-patches@gnu.org

* gnu/packages/coq.scm (coq-interval): Update to 3.4.1.
[source]: Use GIT-FETCH and GIT-FILE-NAME.
[native-inputs]: Add autoconf and automake for remake.
---
 gnu/packages/coq.scm | 24 +++++++++++++++---------
 1 file changed, 15 insertions(+), 9 deletions(-)

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 5a48aede30..11604da30e 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -21,6 +21,7 @@ 
 
 (define-module (gnu packages coq)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
@@ -452,17 +453,22 @@  provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
 (define-public coq-interval
   (package
     (name "coq-interval")
-    (version "3.4.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://gforge.inria.fr/frs/download.php/"
-                                  "file/37524/interval-" version ".tar.gz"))
-              (sha256
-               (base32
-                "023j9sd64brqvjdidqkn5m8d7a93zd9r86ggh573z9nkjm2m7vvg"))))
+    (version "3.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.inria.fr/coqinterval/interval.git")
+             (commit (string-append "interval-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "03q3dfqi3r3f7aji5s06ig4aav9ajcwswwdzi5lrgr69z0m487k4"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("ocaml" ,ocaml)
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("ocaml" ,ocaml)
        ("which" ,which)
        ("coq" ,coq)))
     (propagated-inputs
-- 
2.24.1