diff mbox series

[bug#40304] gnu: Add emacs-dhall-mode.

Message ID 878sjk2byr.fsf@asu.edu
State Accepted
Headers show
Series [bug#40304] gnu: Add emacs-dhall-mode. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

John Soo March 29, 2020, 1:20 a.m. UTC
Hi Guix!

dhall-mode provides language support for the dhall configuration
language.

Thanks!

John

Comments

Nicolas Goaziou March 30, 2020, 5:24 p.m. UTC | #1
Hello,

John Soo <jsoo1@asu.edu> writes:

> dhall-mode provides language support for the dhall configuration
> language.

Thank you.

> +(define-public emacs-dhall-mode
> +  (package
> +    (name "emacs-dhall-mode")
> +    (version "0.1.0")

This version is not accurate. The ".el" file mentions 0.1.3, but I think
we should use Github versioning, i.e., there is no versioning at all, so
we should do the commit + revision dance again, and use "0.1.3" as the
base of the version string.

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri
> +        (git-reference
> +         (url "https://github.com/psibi/dhall-mode")
> +         (commit "ef4d33debe224c6ba37e51a29b9dc8b74f20f1c2")))

This should go in a dedicated variable.

> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "1232y2k4l3bsz90pgis78zxmrw7jv09dfaip21yc1w4vpxfyr384"))))

Nitpick: I usually put `base32' on the same line as the string.

> +    (inputs

Nitpick: Emacs build system uses `propagated-inputs', although this is
the same.

> +     `(("emacs-reformatter" ,emacs-reformatter)))
> +    (build-system emacs-build-system)

Nitpick: `build-system' is usually above

> +    (home-page "https://github.com/psibi/dhall-mode")
> +    (synopsis "Major mode for working with Dhall configuration language")
> +    (description
> +     "Emacs Major mode for working with Dhall configuration
> language.")

The description must be a full sentence.

> +    (license license:gpl2+)))

The license looks wrong. I see GPL3+ in this package.

Could you send an updated patch?

Regards,
diff mbox series

Patch

>From 0dba0653113f6e880cb590fdfab473a8d74d5a5b Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 08:38:05 -0700
Subject: [PATCH] gnu: Add emacs-dhall-mode.

* gnu/packages/emacs-xyz.scm (emacs-dhall-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..1c7a3a4f6d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21776,3 +21777,27 @@  enables modal editing and composition of commands, too.  It combines ideas of
 other Editors like Vim or Kakoune and tries to align them with regular Emacs
 conventions.")
     (license license:gpl3+)))
+
+(define-public emacs-dhall-mode
+  (package
+    (name "emacs-dhall-mode")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/psibi/dhall-mode")
+         (commit "ef4d33debe224c6ba37e51a29b9dc8b74f20f1c2")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1232y2k4l3bsz90pgis78zxmrw7jv09dfaip21yc1w4vpxfyr384"))))
+    (inputs
+     `(("emacs-reformatter" ,emacs-reformatter)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/psibi/dhall-mode")
+    (synopsis "Major mode for working with Dhall configuration language")
+    (description
+     "Emacs Major mode for working with Dhall configuration language.")
+    (license license:gpl2+)))
-- 
2.26.0