diff mbox series

[bug#44089] gnu: Add emacs-wucuo.

Message ID 878sc1k27o.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#44089] gnu: Add emacs-wucuo. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Oct. 20, 2020, 3:26 a.m. UTC
Patch file is attached.  There were some warnings during build 
about functions not being defined.  I believe this is just an 
issue of missing autoload declarations, and I have reported the 
warning to the package's author.

--
Joseph LaFreniere

Comments

Nicolas Goaziou Oct. 20, 2020, 10:11 a.m. UTC | #1
Hello,

Joseph LaFreniere <joseph@lafreniere.xyz> writes:

> Subject: [PATCH] gnu: Add emacs-wucuo.
>
> * gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable.

Thank you. Some comments follow.

> +    (version "0.2.7")

Based on your feedback, upstream released 0.2.8 a few hours ago.

> +       (sha256
> +        (base32
> +         "1iw4jdlqvki95gh7bzl7hjidc2kz9qyc1zjd7klh63gvk0z09700"))))

Nitpick: please move the string on the same line as `base32'.

> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/redguardtoo/wucuo")
> +    (synopsis
> +     "Fastest solution to spell check camel case code or plain text")

Please move the string on the same line as `synopsis'. Also, "fastest"
sounds like a buzzword. I think "Fast" would be more neutral.

> +    (description
> +     "This package provides a spell checker on top of either aspell or
> +hunspell.
> +
> +@itemize
> +@item @code{wucuo-spell-check-file} will spell check one file and report its
> +typos
> +@item If @code{wucuo-flyspell-start-mode} is \"normal\", @code{wucuo-start}
> +runs @code{flyspell-buffer}.  If it's \"normal\", @code{wucuo-start} runs
> +@code{flyspell-region} to check visible region in current window.
> +@item The interval of checking is set by @code{wucuo-update-interval}
> +@end itemize
> +
> +See @code{wucuo-check-nil-font-face} on how to check plain text (text without
> +font)
> +@itemize
> +@item Use @code{wucuo-current-font-face} to detect font face at point
> +@item If @code{wucuo-flyspell-start-mode} is \"normal\",
> +@code{wucuo-spell-check-buffer-max} specifies the maximum size of buffer to
> +check.  If @code{wucuo-flyspell-start-mode} is \"fast\",
> +@code{wucuo-spell-check-region-max} specifies the maximum size of visible
> +region to check.
> +@item You can define a function in @code{wucuo-spell-check-buffer-predicate}.
> +If the function returns t, the spell checking of current buffer will continue.
> +If it returns nil, the spell checking is skipped.
> +@end itemize
> +
> +Here is sample to skip checking in specified major modes,
> +@lisp
> + (setq wucuo-spell-check-buffer-predicate
> +        (lambda ()
> +          (not (memq major-mode
> +                     '(dired-mode
> +                       log-edit-mode
> +                       compilation-mode
> +                       help-mode
> +                       profiler-report-mode
> +                       speedbar-mode
> +                       gud-mode
> +                       calc-mode
> +                       Info-mode)))))
> +@end lisp")

I think most of this belongs to the manual, not to the description. What
about:

  This package provides a spell checker on top of either Aspell or
  Hunspell, and relies on Flyspell internally.  It operates on the
  current region or buffer, a file, or a complete directory.

Could you send an updated patch?

Regards,
Ludovic Courtès Nov. 18, 2020, 10:12 p.m. UTC | #2
Hi Joseph,

A friendly reminder.  :-)

  https://issues.guix.gnu.org/44089

Ludo’.

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

> Hello,
>
> Joseph LaFreniere <joseph@lafreniere.xyz> writes:
>
>> Subject: [PATCH] gnu: Add emacs-wucuo.
>>
>> * gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable.
>
> Thank you. Some comments follow.
>
>> +    (version "0.2.7")
>
> Based on your feedback, upstream released 0.2.8 a few hours ago.
>
>> +       (sha256
>> +        (base32
>> +         "1iw4jdlqvki95gh7bzl7hjidc2kz9qyc1zjd7klh63gvk0z09700"))))
>
> Nitpick: please move the string on the same line as `base32'.
>
>> +    (build-system emacs-build-system)
>> +    (home-page "https://github.com/redguardtoo/wucuo")
>> +    (synopsis
>> +     "Fastest solution to spell check camel case code or plain text")
>
> Please move the string on the same line as `synopsis'. Also, "fastest"
> sounds like a buzzword. I think "Fast" would be more neutral.
>
>> +    (description
>> +     "This package provides a spell checker on top of either aspell or
>> +hunspell.
>> +
>> +@itemize
>> +@item @code{wucuo-spell-check-file} will spell check one file and report its
>> +typos
>> +@item If @code{wucuo-flyspell-start-mode} is \"normal\", @code{wucuo-start}
>> +runs @code{flyspell-buffer}.  If it's \"normal\", @code{wucuo-start} runs
>> +@code{flyspell-region} to check visible region in current window.
>> +@item The interval of checking is set by @code{wucuo-update-interval}
>> +@end itemize
>> +
>> +See @code{wucuo-check-nil-font-face} on how to check plain text (text without
>> +font)
>> +@itemize
>> +@item Use @code{wucuo-current-font-face} to detect font face at point
>> +@item If @code{wucuo-flyspell-start-mode} is \"normal\",
>> +@code{wucuo-spell-check-buffer-max} specifies the maximum size of buffer to
>> +check.  If @code{wucuo-flyspell-start-mode} is \"fast\",
>> +@code{wucuo-spell-check-region-max} specifies the maximum size of visible
>> +region to check.
>> +@item You can define a function in @code{wucuo-spell-check-buffer-predicate}.
>> +If the function returns t, the spell checking of current buffer will continue.
>> +If it returns nil, the spell checking is skipped.
>> +@end itemize
>> +
>> +Here is sample to skip checking in specified major modes,
>> +@lisp
>> + (setq wucuo-spell-check-buffer-predicate
>> +        (lambda ()
>> +          (not (memq major-mode
>> +                     '(dired-mode
>> +                       log-edit-mode
>> +                       compilation-mode
>> +                       help-mode
>> +                       profiler-report-mode
>> +                       speedbar-mode
>> +                       gud-mode
>> +                       calc-mode
>> +                       Info-mode)))))
>> +@end lisp")
>
> I think most of this belongs to the manual, not to the description. What
> about:
>
>   This package provides a spell checker on top of either Aspell or
>   Hunspell, and relies on Flyspell internally.  It operates on the
>   current region or buffer, a file, or a complete directory.
>
> Could you send an updated patch?
>
> Regards,
diff mbox series

Patch

From dd7a1229340ee282af047689a41f95b0f1dbaf7f Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Mon, 19 Oct 2020 22:21:04 -0500
Subject: [PATCH] gnu: Add emacs-wucuo.

* gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable.
---
 gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 62 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5acb8ce6ec..1530cc275f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8637,6 +8637,68 @@  current frame, disabling the mode line, and adding margins to the buffer that
 restrict the text width to 80 characters.")
     (license license:bsd-3)))
 
+(define-public emacs-wucuo
+  (package
+    (name "emacs-wucuo")
+    (version "0.2.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/redguardtoo/wucuo")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1iw4jdlqvki95gh7bzl7hjidc2kz9qyc1zjd7klh63gvk0z09700"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/redguardtoo/wucuo")
+    (synopsis
+     "Fastest solution to spell check camel case code or plain text")
+    (description
+     "This package provides a spell checker on top of either aspell or
+hunspell.
+
+@itemize
+@item @code{wucuo-spell-check-file} will spell check one file and report its
+typos
+@item If @code{wucuo-flyspell-start-mode} is \"normal\", @code{wucuo-start}
+runs @code{flyspell-buffer}.  If it's \"normal\", @code{wucuo-start} runs
+@code{flyspell-region} to check visible region in current window.
+@item The interval of checking is set by @code{wucuo-update-interval}
+@end itemize
+
+See @code{wucuo-check-nil-font-face} on how to check plain text (text without
+font)
+@itemize
+@item Use @code{wucuo-current-font-face} to detect font face at point
+@item If @code{wucuo-flyspell-start-mode} is \"normal\",
+@code{wucuo-spell-check-buffer-max} specifies the maximum size of buffer to
+check.  If @code{wucuo-flyspell-start-mode} is \"fast\",
+@code{wucuo-spell-check-region-max} specifies the maximum size of visible
+region to check.
+@item You can define a function in @code{wucuo-spell-check-buffer-predicate}.
+If the function returns t, the spell checking of current buffer will continue.
+If it returns nil, the spell checking is skipped.
+@end itemize
+
+Here is sample to skip checking in specified major modes,
+@lisp
+ (setq wucuo-spell-check-buffer-predicate
+        (lambda ()
+          (not (memq major-mode
+                     '(dired-mode
+                       log-edit-mode
+                       compilation-mode
+                       help-mode
+                       profiler-report-mode
+                       speedbar-mode
+                       gud-mode
+                       calc-mode
+                       Info-mode)))))
+@end lisp")
+    (license license:gpl3+)))
+
 (define-public emacs-ido-completing-read+
   (package
     (name "emacs-ido-completing-read+")
-- 
2.28.0