diff mbox series

[bug#44255] Add pinebook-pro support.

Message ID 878sbru6wx.fsf@gnu.org
State Accepted
Headers show
Series [bug#44255] Add pinebook-pro support. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Mathieu Othacehe Oct. 27, 2020, 1:37 p.m. UTC
Hello,

Here's a patch adding support for the pinebook-pro. As I do not own one
of those, it would be nice if someone could test it with the following
commands:

--8<---------------cut here---------------start------------->8---
echo "(use-modules (gnu system images pinebook-pro)) pinebook-pro-barebones-os" > /tmp/os.scm
./pre-inst-env guix system disk-image -t pinebook-pro-raw /tmp/os.scm
--8<---------------cut here---------------end--------------->8---

on top of f0c609323e or later.

Thanks,

Mathieu

Comments

Ludovic Courtès Oct. 28, 2020, 3:23 p.m. UTC | #1
Hi!

Mathieu Othacehe <othacehe@gnu.org> skribis:

> Here's a patch adding support for the pinebook-pro. As I do not own one
> of those, it would be nice if someone could test it with the following
> commands:
>
> echo "(use-modules (gnu system images pinebook-pro)) pinebook-pro-barebones-os" > /tmp/os.scm
> ./pre-inst-env guix system disk-image -t pinebook-pro-raw /tmp/os.scm
>
> on top of f0c609323e or later.

I do not have a Pinebook Pro either, but it looks like a great addition.

Should it be mentioned in the manual?

Otherwise LGTM, thanks!

Ludo’.
Mathieu Othacehe Nov. 20, 2020, 4:18 p.m. UTC | #2
Hello,

No comments from pinebook owners so I went ahead.

> Should it be mentioned in the manual?

Yes I plan to write a manual section detailing the different image
types.

Thanks for reviewing,

Mathieu
diff mbox series

Patch

From 9487a2fa3b148ce9b680f7490f436f7f917827bc Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <othacehe@gnu.org>
Date: Tue, 27 Oct 2020 14:05:52 +0100
Subject: [PATCH] image: Add pinebook-pro support.

* gnu/system/images/pinebook-pro.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* gnu/ci.scm (%guix-system-images): Add pinebook-pro-barebones-raw-image.
---
 gnu/ci.scm                         |  3 +-
 gnu/local.mk                       |  1 +
 gnu/system/images/pinebook-pro.scm | 66 ++++++++++++++++++++++++++++++
 3 files changed, 69 insertions(+), 1 deletion(-)
 create mode 100644 gnu/system/images/pinebook-pro.scm

diff --git a/gnu/ci.scm b/gnu/ci.scm
index bf9952a450..8e78cae82c 100644
--- a/gnu/ci.scm
+++ b/gnu/ci.scm
@@ -205,7 +205,8 @@  SYSTEM."
 
 (define %guix-system-images
   (list hurd-barebones-qcow2-image
-        pine64-barebones-raw-image))
+        pine64-barebones-raw-image
+        pinebook-pro-barebones-raw-image))
 
 (define (image-jobs store system)
   "Return a list of jobs that build images for SYSTEM."
diff --git a/gnu/local.mk b/gnu/local.mk
index c6aa58b24f..be3043460e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -650,6 +650,7 @@  GNU_SYSTEM_MODULES =				\
 						\
   %D%/system/images/hurd.scm			\
   %D%/system/images/pine64.scm			\
+  %D%/system/images/pinebook-pro.scm		\
 						\
   %D%/machine.scm				\
 						\
diff --git a/gnu/system/images/pinebook-pro.scm b/gnu/system/images/pinebook-pro.scm
new file mode 100644
index 0000000000..b038e262cb
--- /dev/null
+++ b/gnu/system/images/pinebook-pro.scm
@@ -0,0 +1,66 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu system images pinebook-pro)
+  #:use-module (gnu bootloader)
+  #:use-module (gnu bootloader u-boot)
+  #:use-module (gnu image)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu services)
+  #:use-module (gnu services base)
+  #:use-module (gnu system)
+  #:use-module (gnu system file-systems)
+  #:use-module (gnu system image)
+  #:use-module (srfi srfi-26)
+  #:export (pinebook-pro-barebones-os
+            pinebook-pro-image-type
+            pinebook-pro-barebones-raw-image))
+
+(define pinebook-pro-barebones-os
+  (operating-system
+    (host-name "viso")
+    (timezone "Europe/Paris")
+    (locale "en_US.utf8")
+    (bootloader (bootloader-configuration
+                 (bootloader u-boot-pinebook-pro-rk3399-bootloader)
+                 (target "/dev/vda")))
+    (initrd-modules '())
+    (kernel linux-libre-arm64-generic)
+    (file-systems (cons (file-system
+                          (device (file-system-label "my-root"))
+                          (mount-point "/")
+                          (type "ext4"))
+                        %base-file-systems))
+    (services (cons (service agetty-service-type
+                             (agetty-configuration
+                              (extra-options '("-L")) ; no carrier detect
+                              (baud-rate "115200")
+                              (term "vt100")
+                              (tty "ttyS0")))
+                    %base-services))))
+
+(define pinebook-pro-image-type
+  (image-type
+   (name 'pinebook-pro-raw)
+   (constructor (cut image-with-os arm64-disk-image <>))))
+
+(define pinebook-pro-barebones-raw-image
+  (image
+   (inherit
+    (os->image pinebook-pro-barebones-os #:type pinebook-pro-image-type))
+   (name 'pinebook-pro-barebones-raw-image)))
-- 
2.28.0