diff mbox series

[bug#45664] gnu: Add missing dependency to emacs-eglot.

Message ID 878s985p6y.fsf@asu.edu
State Accepted
Headers show
Series [bug#45664] gnu: Add missing dependency to emacs-eglot. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Soo Jan. 4, 2021, 10:09 p.m. UTC
Hi Guix,

I was using eglot after the update to 1.7 and it crashed with 'void
function project-root'.  Looks like a dependency on project.el was
introduced. This patch should fix the missing dependency.

Thanks!

- John

Comments

Nicolas Goaziou Jan. 10, 2021, 11:11 a.m. UTC | #1
Hello,

John Soo <jsoo1@asu.edu> writes:

> Subject: [PATCH] gnu: Fix missing emacs-eglot dependency on
> emacs-project.

Applied (with a small tweak to commit message). Thank you.

Regards,
diff mbox series

Patch

From 80cb69fb87a4abd227b0bb0da707b65f67c4be34 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Mon, 4 Jan 2021 13:47:23 -0800
Subject: [PATCH] gnu: Fix missing emacs-eglot dependency on emacs-project.

* gnu/packages/emacs-xyz.scm (emacs-eglot): [propagated-inputs] Add
emacs-project.
---
 gnu/packages/emacs-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0071ce5fe7..b8e3c51363 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12592,7 +12592,8 @@  Emacs.")
         (base32 "1zvs144hxq2mmq1h0ynx9hy7yyccb46f3pjg9mgq8v9cw5y678vk"))))
     (build-system emacs-build-system)
     (propagated-inputs
-     `(("emacs-jsonrpc" ,emacs-jsonrpc)))
+     `(("emacs-jsonrpc" ,emacs-jsonrpc)
+       ("emacs-project" ,emacs-project)))
     (home-page "https://github.com/joaotavora/eglot")
     (synopsis "Client for Language Server Protocol (LSP) servers")
     (description
-- 
2.29.2