[bug#53717] gnu: Add rofi-wayland.
Commit Message
Tested on sway session.
* gnu/packages/xdisorg.scm (rofi-wayland): New variable.
---
gnu/packages/xdisorg.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Comments
Andrew schrieb am Dienstag der 01. Februar 2022 um 11:40 +03:
> Tested on sway session.
>
> * gnu/packages/xdisorg.scm (rofi-wayland): New variable.
> ---
> gnu/packages/xdisorg.scm | 35 +++++++++++++++++++++++++++++++++++
> 1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> index ec995c3496..c2bd1d1d5c 100644
> --- a/gnu/packages/xdisorg.scm
> +++ b/gnu/packages/xdisorg.scm
> @@ -53,6 +53,7 @@
> ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
> ;;; Copyright © 2021 jgart <jgart@dismail.de>
> ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
> +;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -1742,6 +1743,40 @@ (define-public rofi
> by name.")
> (license license:expat)))
>
> +(define-public rofi-wayland
> + (package
> + (inherit rofi)
> + (name "rofi-wayland")
> + (version "1.7.2+wayland1")
We usually strip away prefixes and suffixes. FWIW, version 1.7.3 seems
to be available as well.
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/lbonn/rofi"
> + "/releases/download/"
> + version "/rofi-" version ".tar.xz"))
> + (sha256
> + (base32
> + "1smrxjq693z48c7n5pcfrvb0m0vsn6pxn7qpn8bm68j942n8rg3x"))))
> + (build-system meson-build-system)
> + (arguments
> + (substitute-keyword-arguments (package-arguments rofi)
> + ((#:configure-flags flags '())
> + #~(list "-Dxcb=disabled"))))
> + (inputs
> + (list cairo
> + glib
> + libjpeg-turbo
> + librsvg
> + libxkbcommon
> + wayland
> + wayland-protocols
> + pango
> + startup-notification))
> + (description "Rofi is a minimalist application launcher. It memorizes which
> +applications you regularly use and also allows you to search for an application
> +by name.
> +
> +This is a fork with added support for Wayland via layer shell protocol.")))
The home-page should also be changed to point to the fork.
Otherwise, LGTM!
On 2022-02-01, Andrew Tropin wrote:
> * gnu/packages/xdisorg.scm (rofi-wayland): New variable.
rofi-wayland was added in:
04b5450ad852735dfa50961d3afc789b2e52b407 gnu: Add rofi-wayland.
And updated to a newer version in:
19c042ddf80533ba7a615b424dedf9647ca65b0f gnu: rofi-wayland: Update to 1.7.5+wayland2.
Marking as done.
live well,
vagrant
@@ -53,6 +53,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1742,6 +1743,40 @@ (define-public rofi
by name.")
(license license:expat)))
+(define-public rofi-wayland
+ (package
+ (inherit rofi)
+ (name "rofi-wayland")
+ (version "1.7.2+wayland1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lbonn/rofi"
+ "/releases/download/"
+ version "/rofi-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1smrxjq693z48c7n5pcfrvb0m0vsn6pxn7qpn8bm68j942n8rg3x"))))
+ (build-system meson-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments rofi)
+ ((#:configure-flags flags '())
+ #~(list "-Dxcb=disabled"))))
+ (inputs
+ (list cairo
+ glib
+ libjpeg-turbo
+ librsvg
+ libxkbcommon
+ wayland
+ wayland-protocols
+ pango
+ startup-notification))
+ (description "Rofi is a minimalist application launcher. It memorizes which
+applications you regularly use and also allows you to search for an application
+by name.
+
+This is a fork with added support for Wayland via layer shell protocol.")))
+
(define-public rofi-calc
(package
(name "rofi-calc")