diff mbox series

[bug#54078,3/3] gnu: add wayvnc

Message ID 878ru1pa4r.fsf_-_@disroot.org
State New
Headers show
Series None | expand

Commit Message

kitzman Feb. 23, 2022, 9:04 p.m. UTC
I have attached here an updated version of the wayvnc package,
corresponding to the latest 1/3 and 2/3 patches.
diff mbox series

Patch

From 193148229de71411d2aaa561252cfef154ab98d6 Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Wed, 23 Feb 2022 20:47:06 +0200
Subject: [PATCH 3/3] gnu: add wayvnc

---
 gnu/packages/vnc.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index e7b2872074..4e0c27152d 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -385,3 +385,29 @@  (define-public libneatvnc
 authentication, SSH tunneling, and ZRLE or Tight encoding.")
     (license license:isc)))
 
+(define-public wayvnc
+  (package
+    (name "wayvnc")
+    (version "0.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/wayvnc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "wayvnc" (string-append "v" version)))
+              (sha256
+               (base32
+                "0cws9jfnmxqycmlyllvvqzw4jsbrwwk10v9gy8wifv3c61rwgdkk"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config scdoc))
+    (inputs
+     (list libaml libneatvnc zlib libjpeg-turbo gnutls libdrm pixman libglvnd libxkbcommon wayland))
+    (home-page "https://github.com/any1/wayvnc")
+    (synopsis "VNC server for wlroots-based Wayland compositors")
+    (description "This is a VNC server for wlroots-based Wayland compositors
+ (no_entry Gnome and KDE are not supported). It attaches to a running Wayland
+ session, creates virtual input devices, and exposes a single display via the
+ RFB protocol. The Wayland session may be a headless one, so it is also 
+possible to run wayvnc without a physical display attached.")
+    (license license:isc)))
-- 
2.32.0