diff mbox series

[bug#54416] gnu: i2pd: Update to 2.41.0.

Message ID 878rtawiih.fsf@trop.in
State Accepted
Headers show
Series [bug#54416] gnu: i2pd: Update to 2.41.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin March 16, 2022, 5:50 a.m. UTC
* gnu/packages/i2p.scm (i2pd): Update to 2.41.0.
[arguments]: Remove trailing slash to match all libi2pd entries.
---
 gnu/packages/i2p.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Guillaume Le Vaillant March 16, 2022, 3:50 p.m. UTC | #1
Patch pushed as d74d18437e5d18d19706fee52a4061e2a04aca48.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm
index b945018ba8..2320250148 100644
--- a/gnu/packages/i2p.scm
+++ b/gnu/packages/i2p.scm
@@ -32,7 +32,7 @@  (define-module (gnu packages i2p)
 (define-public i2pd
   (package
     (name "i2pd")
-    (version "2.38.0")
+    (version "2.41.0")
     (source
      (origin
        (method git-fetch)
@@ -41,7 +41,7 @@  (define-public i2pd
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1a35grcfw5a9dsj0rnm2i86fjf4px96xbnjj3hkril7hv5jvl37k"))))
+        (base32 "0kh03lb4m8fvlfvq06d4hgwmk43pk7yp7n7y36kb2vplhrjrn2kx"))))
     (build-system cmake-build-system)
     (inputs
      (list boost miniupnpc openssl zlib))
@@ -69,7 +69,7 @@  (define-public i2pd
                                    "./tests")
                  (with-directory-excursion "tests"
                    (substitute* "Makefile"
-                     (("../libi2pd/") (string-append source "/libi2pd/")))
+                     (("../libi2pd") (string-append source "/libi2pd")))
                    (apply invoke "make" "all"
                           `(,@(if parallel-tests?
                                 `("-j" ,(number->string