diff mbox series

[bug#54482] gnu: Add simavr

Message ID 878rt4shrc.fsf@gmail.com
State Accepted
Headers show
Series [bug#54482] gnu: Add simavr | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov March 20, 2022, 4:36 p.m. UTC
Hello,

this patch adds simavr [1] -- an AVR simulator.

Thanks,

- Artyom

References:
1: https://github.com/buserror/simavr

Comments

M March 20, 2022, 5:30 p.m. UTC | #1
Artyom V. Poptsov schreef op zo 20-03-2022 om 19:36 [+0300]:
> +  #:use-module (gnu packages autotools)
> +  #:use-module (gnu packages base)
> +  #:use-module (gnu packages bash)
> +  #:use-module (gnu packages avr)

Why is (gnu packages avr) importing (gnu packages avr)?

> +  #:use-module (gnu packages elf)
> +  #:use-module (gnu packages gl)
> +  #:use-module (gnu packages pkg-config)
> +  #:use-module (gnu packages ncurses)
> +  #:use-module (gnu packages version-control)
> +  #:use-module (gnu packages ruby))

I think most users of avr-libc and avr-toolchain don't need simavr,
so WDYT of defining simavr in a separate module to avoid loading
the (gnu packages ruby) module (which has a large closure, including
much of haskell, java) unless actually necessary?  Benefits are lower
memory usage and less startup time.

Long-term, separating modules (*) a bit more would help with avoiding
circular imports (and maybe eventually, making sure imports aren't
circular at compile-time), makings some ideas for making "guix pull"
faster more feasible
<https://lists.gnu.org/archive/html/guix-devel/2022-02/msg00193.html>
and effective.  I don't think any conclusion was reached upon that
though ...

(*) Though in this case, there doesn't appear to be any circularity,
yet.

Greetings,
Maxime.
diff mbox series

Patch

From 05b3a83a9f0f9b0e08d2675cb9b1a80c6b30114d Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 19 Mar 2022 23:39:54 +0300
Subject: [PATCH] gnu: Add simavr

* gnu/packages/avr.scm (simavr): New variable.
---
 gnu/packages/avr.scm | 74 +++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 73 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 3cc5a6964e..9836cc6305 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@ 
 (define-module (gnu packages avr)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix utils)
+  #:use-module (guix gexp)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix packages)
@@ -35,7 +37,17 @@ 
   #:use-module (gnu packages cross-base)
   #:use-module (gnu packages flashing-tools)
   #:use-module (gnu packages gcc)
-  #:use-module (gnu packages vim))
+  #:use-module (gnu packages vim)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
+  #:use-module (gnu packages avr)
+  #:use-module (gnu packages elf)
+  #:use-module (gnu packages gl)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages version-control)
+  #:use-module (gnu packages ruby))
 
 (define-public avr-binutils
   (package
@@ -181,3 +193,63 @@  inlining, and features an aggressive tree-shaker, eliminating unused top-level
 definitions.  Microscheme has a robust @dfn{Foreign Function Interface} (FFI)
 meaning that C code may be invoked directly from (ms) programs.")
     (license license:expat)))
+
+(define-public simavr
+  (package
+    (name "simavr")
+    (version "1.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/buserror/simavr")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0njz03lkw5374x1lxrq08irz4b86lzj2hibx46ssp7zv712pq55q"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:modules '((guix build gnu-build-system)
+                  (guix build utils))
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'configure)
+                   (replace 'check
+                     (lambda* (#:key outputs #:allow-other-keys)
+                       (when tests?
+                         (invoke "make"
+                                 "-C"
+                                 "tests"
+                                 (string-append "CC=" #$(cc-for-target))
+                                 "RELEASE=1"
+                                 "run_tests")))))
+      #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                           "RELEASE=1"
+                           (string-append "PREFIX=" #$output)
+                           (string-append "DESTDIR=" #$output))))
+    (propagated-inputs
+     (list avr-toolchain))
+    (native-inputs
+     (list autoconf
+           which
+           git
+           automake
+           pkg-config
+           ncurses
+           ruby))
+    (inputs
+     (list bash-minimal libelf freeglut))
+    (home-page "https://github.com/buserror/simavr")
+    (synopsis "Lean, mean and hackable AVR simulator for GNU/Linux and OSX")
+    (description
+     "simavr is a new AVR simulator for GNU/Linux, or any platform that uses
+@command{avr-gcc}.  It uses avr-gcc's own register definition to simplify
+creating new targets for supported AVR devices.  The core was made to be small
+and compact, and hackable so allow quick prototyping of an AVR project.  The
+AVR core is now stable for use with parts with <= 128KB flash, and with
+preliminary support for the bigger parts.  The simulator loads ELF files
+directly, and there is even a way to specify simulation parameterps directly
+in the emulated code using an @code{.elf} section.  You can also load
+multipart HEX files.")
+    (license license:gpl3)))
-- 
2.25.1