diff mbox series

bug#55018: [PATCH] gnu: Add wtime.

Message ID 878rrqlw7d.fsf@gnu.org
State Accepted
Headers show
Series bug#55018: [PATCH] gnu: Add wtime. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Mathieu Othacehe April 27, 2022, 9:19 a.m. UTC
Hello,

> * gnu/packages/task-management.scm (wtime): New variable.

Pushed with the following modifications:

--8<---------------cut here---------------start------------->8---
Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index 17fb8c335e..65b3dc8699 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -23,6 +23,7 @@ 
 
 (define-module (gnu packages task-management)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (gnu packages check)
   #:use-module (gnu packages freedesktop)
@@ -43,6 +44,7 @@  (define-module (gnu packages task-management)
   #:use-module (guix hg-download)
   #:use-module (guix utils)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system python))
@@ -259,8 +261,8 @@  (define-public wtime
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
-       (list (string-append "CC=" ,(cc-for-target))
-             (string-append "PREFIX=" %output))
+       ,#~(list (string-append "CC=" #$(cc-for-target))
+                (string-append "PREFIX=" #$output))
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
@@ -271,10 +273,10 @@  (define-public wtime
        #:tests? #f))  ; No "check" target.
     (home-page "http://wtime.sourceforge.net")
     (synopsis
-     "Command-line utility for tracking time spent working on arbitrary tasks")
+     "Command-line utility for tracking time spent on arbitrary tasks")
     (description
-     "@code{wtime} is a command-line utility for tracking time spent working on
-arbitrary tasks.  All the time data is saved in files residing in the
+     "@code{wtime} is a command-line utility for tracking time spent working
+on arbitrary tasks.  All the time data is saved in files residing in the
 @code{.wtimed} directory in the user's home directory.")
     (license license:x11)))
--8<---------------cut here---------------end--------------->8---