diff mbox series

[bug#55931] gnu: java-commons-lang3: Update to 3.12.0

Message ID 878rq1y8jw.fsf@gmail.com
State Accepted
Headers show
Series [bug#55931] gnu: java-commons-lang3: Update to 3.12.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov June 12, 2022, 7:40 p.m. UTC
Hello,

this patch updates 'java-commons-lang3' to 3.12.0.

The update is required to add 'java-commons-text' package.

Thanks,

- Artyom

Comments

Julien Lepiller June 12, 2022, 8:50 p.m. UTC | #1
Le Sun, 12 Jun 2022 22:40:35 +0300,
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> a écrit :

> Hello,
> 
> this patch updates 'java-commons-lang3' to 3.12.0.
> 
> The update is required to add 'java-commons-text' package.
> 
> Thanks,
> 
> - Artyom
> 

Hi!

The patch looks good and almost works. Unfortunately, the pom file
makes java-jmh fail eventually:

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-enforcer-plugin:3.0.0:enforce
(enforce-maven) on project jmh-parent: Execution enforce-maven of goal
org.apache.maven.plugins:maven-enforcer-plugin:3.0.0:enforce failed:
Plugin org.apache.maven.plugins:maven-enforcer-plugin:3.0.0 or one of
its dependencies could not be resolved: Failed to collect dependencies
at org.apache.maven.plugins:maven-enforcer-plugin:jar:3.0.0 ->
org.apache.maven:maven-artifact:jar:3.8.5 ->
org.apache.commons:commons-lang3:jar:3.12.0: Failed to read artifact
descriptor for org.apache.commons:commons-lang3:jar:3.12.0: Cannot
access central (https://repo.maven.apache.org/maven2) in offline mode
and the artifact org.junit:junit-bom:pom:5.7.1 has not been downloaded
from it before. -> [Help 1]

From what I understand, maven tries to get org.junit:junit-bom because
it is referenced in commons-lang3's pom file, but we don't have it. This
is the only reference to junit-bom though:

<dependencyManagement>
<dependencies>
 <dependency>
  <groupId>org.junit</groupId>
  <artifactId>junit-bom</artifactId>
  <version>5.7.1</version>
  <type>pom</type>
  <scope>import</scope>
 </dependency>
</dependencies>
</dependencyManagement>

I don't know maven well enough, so I'm not sure what that means, but is
junit-bom really needed? Do you think you could add a phase to remove
this dependencyManagement part of the pom file? It wouldn't be the
first time we modify a pom file to make maven happy later in the
dependency chain.

Otherwise, all packages build fine with this update :)
diff mbox series

Patch

From 2d17e4bc1728db8536374b2ddfd97e61b8aed470 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 12 Jun 2022 22:34:28 +0300
Subject: [PATCH] gnu: java-commons-lang3: Update to 3.12.0

* gnu/packages/java.scm (java-commons-lang3): Update to 3.12.0.
---
 gnu/packages/java.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index fcac0c2367..2e28b28e4e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Mike Gerwitz <mtg@gnu.org>
 ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6206,14 +6207,14 @@  included:
 (define-public java-commons-lang3
   (package
     (name "java-commons-lang3")
-    (version "3.9")
+    (version "3.12.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://apache/commons/lang/source/"
                            "commons-lang3-" version "-src.tar.gz"))
        (sha256
-        (base32 "0s4ffbvsyl16c90l45ximsg4dwd8hmz7wsza3p308fw43h6mwhb6"))))
+        (base32 "09dcv1pkdx3hpf06py8p9511f1wkin6jpacdll0c8vxpbi3yfwzv"))))
     (build-system ant-build-system)
     (arguments
      `(#:jar-name "commons-lang3.jar"
-- 
2.25.1