diff mbox series

bug#58436: [PATCH] gnu: Add hunspell-dict-hu.

Message ID 878rlehm9m.fsf@gnu.org
State Accepted
Headers show
Series bug#58436: [PATCH] gnu: Add hunspell-dict-hu. | expand

Commit Message

Ludovic Courtès Oct. 17, 2022, 8:44 a.m. UTC
Hi,

Attila Lendvai <attila@lendvai.name> skribis:

> ---
>
> builds it from source.

Applied with the simplifications below and a commit log.

> testing method: after including this in the profile, LibreOffice Writer started to underline typos in hungarian paragraphs.

Last time I tried, Hunspell dictionaries were not found in LibreOffice:
<https://issues.guix.gnu.org/53147>.

Is this problem gone for you?

Thanks,
Ludo’.

Comments

Attila Lendvai Oct. 17, 2022, 2:39 p.m. UTC | #1
> Last time I tried, Hunspell dictionaries were not found in LibreOffice:
> https://issues.guix.gnu.org/53147.
> 
> Is this problem gone for you?


i don't see any issues with LibreOffice Writer. it's a bit tricky to set the paragraph's language to anything else than english for the first time in a document, but i think it all works as expected.
diff mbox series

Patch

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index fdb987af59..8343f8ffc6 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -46,7 +46,6 @@  (define-module (gnu packages libreoffice)
   #:use-module (gnu packages aspell)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
-  #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
@@ -61,7 +60,6 @@  (define-module (gnu packages libreoffice)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages game-development)
-  #:use-module (gnu packages gawk)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -1016,30 +1014,31 @@  (define-public hunspell-dict-hu
           (base32 "0r22rvqrp5bzgr9sqyap82kibi5z9n6xy5b06si28idqijw7c772"))))
       (build-system gnu-build-system)
       (arguments
-       (list
-        #:make-flags
-        #~(list
-           "myspell"
-           "--jobs=1" ; the Makefile is not ready for parallelism
-           (string-append "SH="  (search-input-file %build-inputs "/bin/bash"))
-           (string-append "AWK=" (search-input-file %build-inputs "/bin/awk")))
-        #:phases
-        #~(modify-phases %standard-phases
-            (replace 'configure
-              (lambda* (#:key outputs #:allow-other-keys)
-                (substitute* "config"
-                  (("/usr/bin/awk")
-                   (search-input-file %build-inputs "/bin/awk")))))
-            (replace 'install           ;no install target
-              (lambda* (#:key outputs #:allow-other-keys)
-                (let* ((out (assoc-ref outputs "out"))
-                       (share (string-append out "/share/hunspell/")))
-                  (install-file "hu_HU.aff" share)
-                  (install-file "hu_HU.dic" share)
-                  #t))))
-          #:tests? #f))                  ; no tests
+       (list #:make-flags
+             #~(list "myspell"
+                     "--jobs=1"     ;the Makefile is not ready for parallelism
+                     (string-append "SH="
+                                    (search-input-file %build-inputs
+                                                       "/bin/bash"))
+                     (string-append "AWK="
+                                    (search-input-file %build-inputs
+                                                       "/bin/awk")))
+             #:phases
+             #~(modify-phases %standard-phases
+                 (replace 'configure
+                   (lambda* (#:key outputs #:allow-other-keys)
+                     (substitute* "config"
+                       (("/usr/bin/awk")
+                        (which "awk")))))
+                 (replace 'install                ;no install target
+                   (lambda* (#:key outputs #:allow-other-keys)
+                     (let* ((out (assoc-ref outputs "out"))
+                            (share (string-append out "/share/hunspell/")))
+                       (install-file "hu_HU.aff" share)
+                       (install-file "hu_HU.dic" share)))))
+             #:tests? #f))                        ; no tests
       (native-inputs
-       (list bash-minimal gawk hunspell m4 recode))
+       (list hunspell m4 recode))
       (synopsis "Hunspell dictionary for Hungarian (hu_HU)")
       (description "This package provides a dictionary for the Hunspell
 spell-checking library.")