diff mbox series

[bug#60271] gnu: Update xfce to 4.18.

Message ID 878riu407x.fsf@rohleder.de
State New
Headers show
Series [bug#60271] gnu: Update xfce to 4.18. | expand

Commit Message

Michael Rohleder Dec. 26, 2022, 4:08 p.m. UTC
Feng Shu <tumashu@163.com> writes:
> I think we should let thunar support $THUNARX_DIRS 
>
> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "THUNARX_DIRS")
> +            (files (list "lib/thunarx-3")))))
>
>
> 1. https://gitlab.xfce.org/xfce/thunar/-/commit/848f1dfb2d2f404efa5371817285236d33b32a5c
> 2. https://gitlab.xfce.org/xfce/thunar/-/merge_requests/232
>

Thanks!
I think, this is a very good idea:

Comments

Feng Shu Dec. 26, 2022, 7:26 p.m. UTC | #1
THUNARX_DIRS will only be considered when build with:

./autogen.sh --with-custom-thunarx-dirs-enabled



please see:


https://gitlab.xfce.org/xfce/thunar/-/merge_requests/232











--
发自我的网易邮箱手机智能版
<br/><br/><br/>


----- Original Message -----
From: "Michael Rohleder" <mike@rohleder.de>
To: "Feng Shu" <tumashu@163.com>
Cc: 60271@debbugs.gnu.org
Sent: Mon, 26 Dec 2022 17:08:02 +0100
Subject: Re: [bug#60271] [PATCH] gnu: Update xfce to 4.18.

Feng Shu <tumashu@163.com> writes:
> I think we should let thunar support $THUNARX_DIRS 
>
> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "THUNARX_DIRS")
> +            (files (list "lib/thunarx-3")))))
>
>
> 1. https://gitlab.xfce.org/xfce/thunar/-/commit/848f1dfb2d2f404efa5371817285236d33b32a5c
> 2. https://gitlab.xfce.org/xfce/thunar/-/merge_requests/232
>

Thanks!
I think, this is a very good idea:
Feng Shu Dec. 26, 2022, 10:04 p.m. UTC | #2
Michael Rohleder <mike@rohleder.de> writes:


I suggest include the below thunar plugins when we update to xfce-4.18,
so we can test thunar THUNARX-DIRS feature with these plugins help.

1. thunar-archive-plugin
2. thunar-media-tags-plugin
3. thunar-shares-plugin
4. thunar-vcs-plugin


patchs of the 4 plugins can be found in:

  https://issues.guix.gnu.org/54525#2-lineno22

thunar-archive-plugin may have new version.


If possible, I suggest xfce package depend on thunar-archive-plugin.

--
Michael Rohleder Dec. 27, 2022, 10:11 a.m. UTC | #3
Feng Shu <tumashu@163.com> writes:
> I suggest include the below thunar plugins when we update to xfce-4.18,
> so we can test thunar THUNARX-DIRS feature with these plugins help.
>
> 1. thunar-archive-plugin
> 2. thunar-media-tags-plugin
> 3. thunar-shares-plugin
> 4. thunar-vcs-plugin
>
>
> patchs of the 4 plugins can be found in:
>
>   https://issues.guix.gnu.org/54525#2-lineno22
>
> thunar-archive-plugin may have new version.
>
>
> If possible, I suggest xfce package depend on thunar-archive-plugin.

I think we can (and should) do this as a separate issue and patches.
Its a nice (and needed) feature, but 4.18 (except thunar plugins?) runs
w/o it, so I guess its easy (easier to test) to do after this patchset
has been merged, because adding more patches would also make the review
and work of the committer harder.

WDYT?
Feng Shu Dec. 27, 2022, 10:40 a.m. UTC | #4
Let us see others opinions :)




--
发自我的网易邮箱手机智能版
<br/><br/><br/>


----- Original Message -----
From: "Michael Rohleder" <mike@rohleder.de>
To: "Feng Shu" <tumashu@163.com>
Cc: 60271@debbugs.gnu.org
Sent: Tue, 27 Dec 2022 11:11:06 +0100
Subject: Re: [bug#60271] [PATCH] gnu: Update xfce to 4.18.

Feng Shu <tumashu@163.com> writes:
> I suggest include the below thunar plugins when we update to xfce-4.18,
> so we can test thunar THUNARX-DIRS feature with these plugins help.
>
> 1. thunar-archive-plugin
> 2. thunar-media-tags-plugin
> 3. thunar-shares-plugin
> 4. thunar-vcs-plugin
>
>
> patchs of the 4 plugins can be found in:
>
>   https://issues.guix.gnu.org/54525#2-lineno22
>
> thunar-archive-plugin may have new version.
>
>
> If possible, I suggest xfce package depend on thunar-archive-plugin.

I think we can (and should) do this as a separate issue and patches.
Its a nice (and needed) feature, but 4.18 (except thunar plugins?) runs
w/o it, so I guess its easy (easier to test) to do after this patchset
has been merged, because adding more patches would also make the review
and work of the committer harder.

WDYT?
diff mbox series

Patch

From 230449327ed4cc98b14b80fa6d9a44941751b906 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Mon, 26 Dec 2022 16:55:39 +0100
Subject: [PATCH] gnu: xfce: Propagate search paths of 'thunar'.

* gnu/packages/xfce.scm (xfce)[native-search-paths]: Add thunar.
---
 gnu/packages/xfce.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 9409045996..858e08ca15 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1109,8 +1109,8 @@  (define-public xfce
      ;; Default font that applications such as IceCat require.
      (list font-dejavu))
     (native-search-paths
-     ;; For finding panel plugins.
-     (package-native-search-paths xfce4-panel))
+     ;; For finding panel and thunar plugins.
+     (package-native-search-paths xfce4-panel thunar))
     (home-page "https://www.xfce.org/")
     (synopsis "Desktop environment (meta-package)")
     (description
-- 
2.38.1