diff mbox series

[bug#68918] gnu: go-github-com-operatorfoundation-ed25519: Add missing input.

Message ID 878r4112yh.fsf@troyfigiel.com
State New
Headers show
Series [bug#68918] gnu: go-github-com-operatorfoundation-ed25519: Add missing input. | expand

Commit Message

Troy Figiel Feb. 4, 2024, 12:30 a.m. UTC
* gnu/packages/golang-crypto.scm (go-github-com-operatorfoundation-ed25519)
[native-inputs]: Add go-golang-org-x-crypto.
---
 gnu/packages/golang-crypto.scm | 2 ++
 1 file changed, 2 insertions(+)


base-commit: abeffc82379c4f9bd2e6226ea27453b22cb4e0c8

Comments

Troy Figiel Feb. 4, 2024, 12:42 a.m. UTC | #1
Currently, this has no effect on the build because the test file
extra25519/extra25519_test.go that contains this requirement is not
being tested and hence not being built.

This patch already adds go-golang-org-x-crypto to native-inputs, so
running all tests in the future, i.e. a change in the check phase, does
not break the build.

Best wishes,

Troy
Sharlatan Hellseher Feb. 5, 2024, 10:39 p.m. UTC | #2
Hi,

Pushed as 1eda62a26692f20bc29d32f3ee09ac719e7483a5 to master.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 688523a8f7..c8aa7fec0a 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -699,6 +699,8 @@  (define-public go-github-com-operatorfoundation-ed25519
                (delete-file-recursively
                 (string-append "src/" import-path "/testdata"))
                #t)))))
+      (native-inputs
+       (list go-golang-org-x-crypto))
       (home-page "https://github.com/OperatorFoundation/ed25519")
       (synopsis "Ed25519 for go")
       (description "Package ed25519 implements the Ed25519 signature