diff mbox series

[bug#68617] gnu: Add go-github-com-gabriel-vasile-mimetype.

Message ID 878r404sxu.fsf@gmail.com
State New
Headers show
Series [bug#68617] gnu: Add go-github-com-gabriel-vasile-mimetype. | expand

Commit Message

Artyom V. Poptsov Feb. 4, 2024, 6:58 a.m. UTC
Hello,

I took into account the comments from Sharlatan Hellseher and updated
the patch.
Thanks,
- avp
diff mbox series

Patch

From c090118a564bd6c3b2672f5422490b765efcc56e Mon Sep 17 00:00:00 2001
Message-ID: <c090118a564bd6c3b2672f5422490b765efcc56e.1707029680.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 20 Jan 2024 21:07:27 +0300
Subject: [PATCH] gnu: Add go-github-com-gabriel-vasile-mimetype.

* gnu/packages/golang.scm (go-github-com-gabriel-vasile-mimetype): New
  variable.

Change-Id: Icb1624eb9a890b6f711dacf5ff80f15b041f3b7d
---
 gnu/packages/golang.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 014ca01602..966a8b0eaa 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4112,6 +4112,42 @@  (define-public go-github-com-technoweenie-multipartstreamer
 without reading the entire content into memory.")
     (license license:expat)))
 
+(define-public go-github-com-gabriel-vasile-mimetype
+  (package
+    (name "go-github-com-gabriel-vasile-mimetype")
+    (version "1.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gabriel-vasile/mimetype")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11swnjczhrza0xi8q2wlk056nnbcghm44vqs52zfv6rwqvy6imhj"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.20
+      #:import-path "github.com/gabriel-vasile/mimetype"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'add-supported-mimes-md
+            (lambda* (#:key inputs #:allow-other-keys #:rest args)
+              ;; This file needs to be available for writing during the
+              ;; tests otherwise they will fail.
+              (let ((file
+                     "src/github.com/gabriel-vasile/mimetype/supported_mimes.md"))
+                (invoke "touch" file)
+                (chmod file #o644)))))))
+    (propagated-inputs (list go-golang-org-x-net))
+    (home-page "https://github.com/gabriel-vasile/mimetype")
+    (synopsis "Golang library for media type and file extension detection")
+    (description
+     "A fast Golang library for media type and file extension detection, based on
+magic numbers .")
+    (license license:expat)))
+
 (define-public go-github-com-tevino-abool
   (let ((commit
           "3c25f2fe7cd0ef3eabefce1d90efd69a65d35b12")

base-commit: abeffc82379c4f9bd2e6226ea27453b22cb4e0c8
-- 
2.41.0