diff mbox series

[bug#71903,Fix] emacs-gnosis: Use proper desc & alph order of inputs

Message ID 878qyjhgjl.fsf@thanosapollo.org
State New
Headers show
Series [bug#71903,Fix] emacs-gnosis: Use proper desc & alph order of inputs | expand

Commit Message

Thanos Apollo July 2, 2024, 5:03 p.m. UTC
Fixing the patch for adding gnosis by having proper description & order
of inputs alphabetically.
diff mbox series

Patch

From d16353d974eab6ad2a9d6511ba7d0183f8368ebc Mon Sep 17 00:00:00 2001
Message-ID: <d16353d974eab6ad2a9d6511ba7d0183f8368ebc.1719939707.git.public@thanosapollo.org>
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 19:31:35 +0300
Subject: [PATCH] gnu: Add emacs-gnosis.

* gnu/packages/emacs-xyz.scm (emacs-gnosis): New variable.

Change-Id: I5757adf1b1b5f19f34fce60e487f4420e8785521
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a13af2a5a1..2156bfbee6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17982,6 +17982,30 @@  (define-public emacs-gn-mode
 are common in Chromium-derived projects.")
     (license license:bsd-3)))
 
+(define-public emacs-gnosis
+  (let ((commit "6df4a3d342bee27ef6891dc4930dd3ff17c52c31"))
+    (package
+      (name "emacs-gnosis")
+      (version "0.3.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.thanosapollo.org/gnosis")
+               (commit commit)))
+         (sha256
+          (base32
+           "18d59gw9k1aj7ki2555vb4mdbrpsz9ib5lkcshf6k0p0qxkzqcxz"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-compat
+             emacs-emacsql))
+      (home-page "https://thanosapollo.org/projects/gnosis")
+      (synopsis "Spaced Repetition System for GNU Emacs")
+      (description "Gnosis is a spaced repetition system for note-taking and self-testing where notes are formatted as Question/Answer/Explanation. Notes are reviewed at spaced intervals based on the success or failure in recalling the answer to each question.")
+      (license license:gpl3+))))
+
 (define-public emacs-drag-stuff
   (package
     (name "emacs-drag-stuff")

base-commit: 69089674bb9fb2cc7b3285b73fb7dda7d99a2550
prerequisite-patch-id: d920223ad4dd8c4e1b3e2e95b047ace057eeddf8
-- 
2.45.2