bug#34146: [PATCH] gnu: Add ghc-c2hs.

Message ID 877eevdmvd.fsf@gnu.org
State Accepted
Headers show
Series bug#34146: [PATCH] gnu: Add ghc-c2hs. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès Jan. 23, 2019, 10:34 p.m. UTC
Gabriel Hondet <gabrielhondet@gmail.com> skribis:

> * gnu/packages/haskell.scm (ghc-c2hs): New variable.

Applied with the changes below.

It’d be nice to report the test failures upstream since it could be
fairly problematic for such a tool to fail to parse C headers.

Thanks,
Ludo’.

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 02af900354..b8ea36852b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11429,7 +11429,10 @@  man pages with practical examples.")
        ("ghc-text" ,ghc-text)
        ("gcc" ,gcc)))
     (arguments
-     `(#:tests? #f ;some tests fail because of syntax errors
+     `(;; XXX: Test failures are induced by a parse error in <bits/floatn.h>
+       ;; of glibc 2.28.
+       #:tests? #f
+
        #:phases
        (modify-phases %standard-phases
          (add-before 'check 'set-cc
@@ -11450,8 +11453,7 @@  man pages with practical examples.")
                (delete-file-recursively cc-dir)
                #t))))))
     (home-page "https://github.com/haskell/c2hs")
-    (synopsis
-     "C->Haskell FFI tool that gives some cross-language type safety")
+    (synopsis "Create Haskell bindings to C libraries")
     (description "C->Haskell assists in the development of Haskell bindings to
 C libraries.  It extracts interface information from C header files and
 generates Haskell code with foreign imports and marshaling.  Unlike writing