[bug#35116,staging] Add python-robotframework et al.

Message ID 877ec6prto.fsf@kwak.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#35116,staging] Add python-robotframework et al. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Maxim Cournoyer April 7, 2019, 12:44 a.m. UTC
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello!
>
> Here's a series adding a few new Python packages to support Robot
> Framework, as well as the Emacs mode to accompany it.
>
> python-pygithub will not build reproducibly until a fix is applied to
> the Python build system (to be submitted in another change).
>
> Thanks!
>
> Maxim

This patch dependes on Robot Framework, so I'm adding it here as well;
it is a linter.
Maxim

Patch

From 7f8e3fdad251258156ca12b725820f3482331f01 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Sat, 6 Apr 2019 20:06:50 -0400
Subject: [PATCH] gnu: Add python-robotframework-lint.

* gnu/packages/python-xyz.scm (python-robotframework-lint): New variable.
---
 gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6c23dad1bf..8d08ef3859 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2782,6 +2782,42 @@  acceptance testing, acceptance test driven development (ATDD), and robotic
 process automation (RPA).")
     (license license:asl2.0)))
 
+(define-public python-robotframework-lint
+  ;; There is no properly tagged release; the commit below seems to correspond
+  ;; to the 0.9 stable release available from PyPI.  The tests are not
+  ;; included in the PyPI archive, so we fetch the sources from the upstream
+  ;; Git repo.
+  (let ((commit "e851879bab1f63e4e53b34a4dc8a67ed95102830")
+        (revision "1"))
+    (package
+      (name "python-robotframework-lint")
+      (version (git-version "0.9.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/boakley/robotframework-lint.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1p6fknqg5sb9qz5857ji4a877657vgfjm5v3zn45994parx6ml1m"))))
+      (build-system python-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (replace 'check
+             (lambda _
+               (invoke "python" "-m" "robot" "-A"
+                       "tests/conf/default.args" "tests"))))))
+      (propagated-inputs
+       `(("python-robotframework" ,python-robotframework)))
+      (home-page "https://github.com/boakley/robotframework-lint/")
+      (synopsis "Static analysis tool (linter) for Robot Framework")
+      (description "This package provides the @code{rflint} command-line
+utility, a static analysis tool (linter) for Robot Framework source files.")
+      (license license:asl2.0))))
+
 (define-public python-robotframework-sshlibrary
   (package
     (name "python-robotframework-sshlibrary")
-- 
2.20.1