diff mbox series

[bug#36409] gnu: Add beets-bandcamp.

Message ID 877e968rtq.fsf@sdf.lonestar.org
State Accepted
Headers show
Series [bug#36409] gnu: Add beets-bandcamp. | expand

Commit Message

Jakob L. Kreuze June 28, 2019, 12:41 a.m. UTC
* gnu/packages/music.scm (beets-bandcamp): New variable.
---
 gnu/packages/music.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

swedebugia June 28, 2019, 5 a.m. UTC | #1
On 2019-06-28 02:41, Jakob L. Kreuze wrote:
> * gnu/packages/music.scm (beets-bandcamp): New variable.
> ---
>   gnu/packages/music.scm | 28 ++++++++++++++++++++++++++++
>   1 file changed, 28 insertions(+)
> 
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index ca9cbd3343..fd8898a706 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -21,6 +21,7 @@
>   ;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
>   ;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
>   ;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
> +;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
>   ;;;
>   ;;; This file is part of GNU Guix.
>   ;;;
> @@ -129,6 +130,7 @@
>     #:use-module (gnu packages tcl)
>     #:use-module (gnu packages texinfo)
>     #:use-module (gnu packages tex)
> +  #:use-module (gnu packages time)
>     #:use-module (gnu packages tls)
>     #:use-module (gnu packages version-control)
>     #:use-module (gnu packages video)
> @@ -2816,6 +2818,32 @@ metadata as it goes using the MusicBrainz database.  Then it provides a variety
>   of tools for manipulating and accessing your music.")
>       (license license:expat)))
>   
> +(define-public beets-bandcamp
> +  (package
> +    (name "beets-bandcamp")
> +    (version "0.1.3")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "beets-bandcamp" version))
> +              (sha256
> +               (base32
> +                "04awg0zdhhg5h510fc1p3qkvr2l1qm6nf85hlr9z8im8a7xlka0i"))))
> +    (build-system python-build-system)
> +    (arguments '(#:tests? #f)) ; there are no tests
> +    (propagated-inputs
> +     `(("beets" ,beets)
> +       ("python-isodate" ,python-isodate)))
> +    (inputs
> +     `(("python-six" ,python-six)
> +       ("python-requests" ,python-requests)
> +       ("python-beautifulsoup4" ,python-beautifulsoup4)))
> +    (home-page "https://github.com/unrblt/beets-bandcamp")
> +    (synopsis "Bandcamp plugin for beets")
> +    (description "Plugin for beets to automatically obtain tag data from
> +https://bandcamp.com/.  The plugin is also capable of getting lyrics for songs
> +and album art using the beets FetchArt plugin.")
> +    (license license:gpl2)))
> +
>   (define-public milkytracker
>     (package
>       (name "milkytracker")
> 

LGTM. It is reproducible.
Tobias Geerinckx-Rice June 28, 2019, 12:25 p.m. UTC | #2
Jakob,

Pushed with minor cosmetic adjustments as 
4ee2cce327ce839f471fb28a095fe7299ed822af.

Jakob L. Kreuze wrote:
> +    (description "Plugin for beets to automatically obtain tag 
> data from
> +https://bandcamp.com/.  The plugin is also capable of getting 
> lyrics for songs
> +and album art using the beets FetchArt plugin.")

Thank you for (presumably) taking the time to write a better 
description than upstream's.

I've tweaked it only slightly (mainly starting with a full 
sentence & adding @uref for the URL), promise.

Kind regards,

T G-R
Jakob L. Kreuze June 28, 2019, 1:42 p.m. UTC | #3
Hi Tobias,

Tobias Geerinckx-Rice <me@tobias.gr> writes:

> Thank you for (presumably) taking the time to write a better
> description than upstream's.

Yeah, I didn't think upstream's description fit the guidelines in the
manual's "Synopses and Descriptions" section.

> I've tweaked it only slightly (mainly starting with a full sentence &
> adding @uref for the URL), promise.

Much appreciated, thank you :]

Regards,
Jakob
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ca9cbd3343..fd8898a706 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -129,6 +130,7 @@ 
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tex)
+  #:use-module (gnu packages time)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages video)
@@ -2816,6 +2818,32 @@  metadata as it goes using the MusicBrainz database.  Then it provides a variety
 of tools for manipulating and accessing your music.")
     (license license:expat)))
 
+(define-public beets-bandcamp
+  (package
+    (name "beets-bandcamp")
+    (version "0.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "beets-bandcamp" version))
+              (sha256
+               (base32
+                "04awg0zdhhg5h510fc1p3qkvr2l1qm6nf85hlr9z8im8a7xlka0i"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f)) ; there are no tests
+    (propagated-inputs
+     `(("beets" ,beets)
+       ("python-isodate" ,python-isodate)))
+    (inputs
+     `(("python-six" ,python-six)
+       ("python-requests" ,python-requests)
+       ("python-beautifulsoup4" ,python-beautifulsoup4)))
+    (home-page "https://github.com/unrblt/beets-bandcamp")
+    (synopsis "Bandcamp plugin for beets")
+    (description "Plugin for beets to automatically obtain tag data from
+https://bandcamp.com/.  The plugin is also capable of getting lyrics for songs
+and album art using the beets FetchArt plugin.")
+    (license license:gpl2)))
+
 (define-public milkytracker
   (package
     (name "milkytracker")