diff mbox series

bug#37429: [PATCH] gnu: Add autocutsel.

Message ID 877e62puhp.fsf@gnu.org
State Accepted
Headers show
Series bug#37429: [PATCH] gnu: Add autocutsel. | expand

Commit Message

Ludovic Courtès Sept. 20, 2019, 8:45 p.m. UTC
Hi Wiktor,

Wiktor Żelazny <wz@freeshell.de> skribis:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/xdisorg.scm (autocutsel): New variable.

I took the liberty to adjust as show below: the license is ‘gpl2+’
because headers carry the “or any later version” wording.  The other
changes are just purely cosmetic, for the sake of consistency.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4d7119a693..10ffa6f695 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1716,21 +1716,21 @@  Wayland.")
     (version "0.10.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://github.com/sigmike/" name
+              (uri (string-append "https://github.com/sigmike/autocutsel"
                                   "/releases/download/" version "/"
-                                  name "-" version ".tar.gz"))
+                                  "autocutsel-" version ".tar.gz"))
               (sha256
                (base32
                 "0gsys2dzh4az51ndcsabhlbbrjn2nm75lnjr45kg6r8sm8q66dx2"))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f)) ; no "check" target
-    (native-inputs `(("libx11"            ,libx11)
-                     ("libxaw"            ,libxaw)))
+    (native-inputs `(("libx11" ,libx11)
+                     ("libxaw" ,libxaw)))
     (home-page "https://www.nongnu.org/autocutsel/")
     (synopsis "Automated X11 clipboard and cutbuffer synchronization")
     (description "@code{autocutsel} tracks changes in the server's cutbuffer
 and clipboard selection.  When the clipboard is changed, it updates the
 cutbuffer.  When the cutbuffer is changed, it owns the clipboard selection.
 The cutbuffer and clipboard selection are always synchronized.")
-    (license license:gpl2)))
+    (license license:gpl2+)))