From 5b4430dce26b607cc0ebf443a33a3607a3b33eb1 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 5 Dec 2019 07:48:30 -0600
Subject: [PATCH 3/3] gnu: emacs-telega: Properly install alists.
* gnu/packages/emacs-xyz.scm (emacs-telega)[arguments]: Telega has an etc
directory that needs to be installed to emacs site-lisp dir. This patch adds
that functionality.
---
gnu/packages/emacs-xyz.scm | 18 +++++++++++++++---
1 file changed, 15 insertions(+), 3 deletions(-)
@@ -20019,11 +20019,23 @@ fish-completion. It can be used in both Eshell and M-x shell.")
;; Build emacs-side using `emacs-build-system'
(add-after 'compress-documentation 'emacs-add-source-to-load-path
(assoc-ref emacs:%standard-phases 'add-source-to-load-path))
- (add-after 'emacs-set-emacs-load-path 'emacs-install
+ (add-after 'emacs-add-source-to-load-path 'emacs-install
(assoc-ref emacs:%standard-phases 'install))
- (add-after 'emacs-install 'emacs-build
+ ;; This step adds subdir /etc to the site-lisp dir
+ ;; which is needed for images, notification sounds,
+ ;; and various alists.
+ ;; TODO: Replace with `#:include' method used by
+ ;; emacs-build-system.
+ (add-after 'emacs-install 'emacs-install-etc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion "."
+ (invoke "cp" "-r" "etc/"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/")))
+ #t))
+ (add-after 'emacs-install-etc 'emacs-build
(assoc-ref emacs:%standard-phases 'build))
- (add-after 'emacs-install 'emacs-make-autoloads
+ (add-after 'emacs-build 'emacs-make-autoloads
(assoc-ref emacs:%standard-phases 'make-autoloads)))))
(propagated-inputs
`(("emacs-visual-fill-column" ,emacs-visual-fill-column)))
--
2.24.0