From 90fd350498ab548d2006e3e7c0c86ae5e87d1255 Mon Sep 17 00:00:00 2001
From: Alex ter Weele <alex.ter.weele@gmail.com>
Date: Thu, 19 Dec 2019 20:43:34 -0500
Subject: [PATCH] gnu: Add emacs-punpun-theme.
* gnu/packages/emacs-xyz.scm (emacs-punpun-theme): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
@@ -19876,6 +19876,31 @@ is cast on a light backdrop (Modus Operandi) and another where light text is
displayed against a dark background (Modus Vivendi).")
(license license:gpl3+)))
+(define-public emacs-punpun-theme
+ (let ((commit "2f78125609277b2478abdebd8f9d5ee10a823b65")
+ (revision "0"))
+ (package
+ (name "emacs-punpun-theme")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wasamasa/punpun-theme.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sgxrj3igzq86h3whfymxf4qzv9kpvcrlhbvjmnp7fwrplys0n7d"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/wasamasa/punpun-theme")
+ (synopsis "Bleak Emacs theme")
+ (description
+ "A bleak theme. Uses shades of gray and the occasional splash of
+color. Designed for 256-color terminals. Comes in light and dark!")
+ (license license:gpl3))))
+
+
(define-public emacs-elixir-mode
(package
(name "emacs-elixir-mode")
--
2.24.1