From cf60d325dcc6b31f0c040c947e1e882cdaea585c Mon Sep 17 00:00:00 2001
From: Evan Straw <evan.straw99@gmail.com>
Date: Tue, 31 Dec 2019 15:31:58 -0800
Subject: [PATCH 2/3] gnu: Add liquid-dsp.
* gnu/packages/ham-radio.scm (liquid-dsp): New variable.
---
gnu/packages/ham-radio.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
@@ -22,6 +22,8 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libusb)
@@ -127,3 +129,30 @@ satellites, the POES NOAA weather satellite series. These transmissions are
on a frequency of 137 MHz. They can be received using an inexpensive antenna
and a dedicated receiver.")
(license license:gpl2+)))
+
+(define-public liquid-dsp
+ (package
+ (name "liquid-dsp")
+ (version "1.3.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jgaeddert/liquid-dsp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("autoconf" ,autoconf)))
+ (home-page "https://liquidsdr.org")
+ (synopsis "Digital signal processing library for software-defined radios")
+ (description "liquid-dsp is a digital signal processing (DSP) library
+designed specifically for software-defined radios on embedded platforms. The
+aim is to provide a lightweight DSP library that does not rely on a myriad of
+external dependencies or proprietary and otherwise cumbersome frameworks. All
+signal processing elements are designed to be flexible, scalable, and dynamic,
+including filters, filter design, oscillators, modems, synchronizers, complex
+mathematical operations, and much more.")
+ (license license:expat)))
+
--
2.20.1