diff mbox series

[bug#40416] Add python-titlecase.

Message ID 877dywcqlq.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#40416] Add python-titlecase. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 3, 2020, 7:32 p.m. UTC

Comments

Efraim Flashner April 9, 2020, 9:08 p.m. UTC | #1
Thanks. Patch pushed.
diff mbox series

Patch

From e566b6434b8696be3d12cd37f3362752c30433e8 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Fri, 3 Apr 2020 15:28:46 -0400
Subject: [PATCH] gnu: Add python-titlecase.

* gnu/packages/python-xyz.scm (python-titlecase): New variable.
---
 gnu/packages/python-xyz.scm | 27 ++++++++++++++++++++++++++-
 1 file changed, 26 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5bf2f5a3d..cf4ef40895 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8,7 +8,7 @@ 
 ;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
 ;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2016, 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
 ;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
@@ -18726,3 +18726,28 @@  HTML-containing files.")
 usable as a configuration language.  This Python package implements parsing and
 dumping of JSON5 data structures.")
     (license license:asl2.0)))
+
+(define-public python-titlecase
+  (package
+    (name "python-titlecase")
+    (version "0.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "titlecase" version))
+       (sha256
+        (base32
+         "0486i99wf8ssa7sgn81fn6fv6i4rhhq6n751bc740b3hzfbpmpl4"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page
+     "https://github.com/ppannuto/python-titlecase")
+    (synopsis
+     "Python library to capitalize strings similar to book titles")
+    (description
+     "Python-Titlecase is a Python Port of John Gruber's titlecase.pl.
+It capitalizes (predominantly English) strings in a way that is similar to
+book titles, using the New York Times Manual of Style to leave certain words
+lowercase.")
+    (license license:expat)))
-- 
2.26.0