diff mbox series

[bug#41460] gnu: Add python-pyfiglet

Message ID 877dx4at6p.fsf@alice.lan
State Accepted
Headers show
Series [bug#41460] gnu: Add python-pyfiglet | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Edouard Klein May 22, 2020, 3:24 p.m. UTC
* gnu/packages/python-xyz (python-pyfiglet): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Marius Bakke May 30, 2020, 12:58 p.m. UTC | #1
Edouard Klein <edk@beaver-labs.com> writes:

> * gnu/packages/python-xyz (python-pyfiglet): New variable.

Thanks!

[...]

> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index d8552276fc..7a1312e87b 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -20133,3 +20133,21 @@ using multi-select lists, confirmations, free text prompts, completion, etc.")
>  background tasks, and check these tasks' health by hand, relaunch them, etc. by attaching
>  to the corresponding pane in tmux.")
>      (license license:agpl3+)))
> +
> +(define-public python-pyfiglet

This depends on some missing context in python-xyz.scm and does not
apply.  Can you rebase this on 'master'?

> +  (package
> +  (name "python-pyfiglet")

The indentation here is off.  If you are not using Emacs, there is a
script to help with the indentation.

> +  (version "0.8.post1")
> +  (source
> +    (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "pyfiglet" version))
> +      (sha256
> +        (base32
> +          "0f9n2076ga2ccsg174k2d7n0z4d44ml96yzc72s6g4nhalbk5hn6"))))
> +  (build-system python-build-system)
> +  (home-page "https://github.com/pwaller/pyfiglet")
> +  (synopsis "Pure-python FIGlet implementation")
> +  (description "This module lets you draw large letter from ordinary characters
> + in pure Python.")

It would be good to define FIGlet here somewhere.

Can you send an updated patch?
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d8552276fc..7a1312e87b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20133,3 +20133,21 @@  using multi-select lists, confirmations, free text prompts, completion, etc.")
 background tasks, and check these tasks' health by hand, relaunch them, etc. by attaching
 to the corresponding pane in tmux.")
     (license license:agpl3+)))
+
+(define-public python-pyfiglet
+  (package
+  (name "python-pyfiglet")
+  (version "0.8.post1")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "pyfiglet" version))
+      (sha256
+        (base32
+          "0f9n2076ga2ccsg174k2d7n0z4d44ml96yzc72s6g4nhalbk5hn6"))))
+  (build-system python-build-system)
+  (home-page "https://github.com/pwaller/pyfiglet")
+  (synopsis "Pure-python FIGlet implementation")
+  (description "This module lets you draw large letter from ordinary characters
+ in pure Python.")
+  (license license:expat)))