diff mbox series

[bug#42368] gnu: freeorion: Build with boost-with-python2.

Message ID 877dv4byhm.fsf@GlaDOS.home
State Accepted
Headers show
Series [bug#42368] gnu: freeorion: Build with boost-with-python2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Diego Nicola Barbato July 15, 2020, 3:15 p.m. UTC
Hey Guix,

Migrating Boost from Python 2 to Python 3 broke FreeOrion.  The
following patch fixes that by building it with boost-with-python2
instead of boost.

Regards,

Diego

Comments

Nicolas Goaziou July 17, 2020, 12:03 a.m. UTC | #1
Hello,

Diego Nicola Barbato <dnbarbato@posteo.de> writes:

> * gnu/packages/games.scm (freeorion)[inputs]: Replace boost with
> boost-with-python2.

Applied. Thank you.

Regards,
diff mbox series

Patch

From bbc61b99e650c26ea57813d6ac4479b4a45bb9fe Mon Sep 17 00:00:00 2001
From: Diego Nicola Barbato <dnbarbato@posteo.de>
Date: Wed, 15 Jul 2020 11:58:38 +0200
Subject: [PATCH] gnu: freeorion: Build with boost-with-python2.

* gnu/packages/games.scm (freeorion)[inputs]: Replace boost with
boost-with-python2.
---
 gnu/packages/games.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5de6dbf4ac..e475997a54 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9464,7 +9464,7 @@  win.")
                   (string-append "\"" roboto-dir "Roboto-" type ".ttf\");")))
                #t))))))
     (inputs
-     `(("boost" ,boost)
+     `(("boost" ,boost-with-python2)
        ("boost_signals" ,boost-signals2)
        ("font-dejavu" ,font-dejavu)
        ("font-roboto" ,font-google-roboto)
-- 
2.26.2