diff mbox series

[bug#52386] gnu: Add emacs-dpd.

Message ID 877dces4fs.fsf@trop.in
State Accepted
Headers show
Series [bug#52386] gnu: Add emacs-dpd. | expand

Commit Message

Andrew Tropin Dec. 9, 2021, 5:59 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-dpd): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Dec. 9, 2021, 8:15 a.m. UTC | #1
Hello,

Andrew Tropin <andrew@trop.in> writes:

> * gnu/packages/emacs-xyz.scm (emacs-dpd): New variable.

Thank you. I applied your patch with the following changes:

> +(define-public emacs-dpd
> +  (package
> +    (name "emacs-dpd")
> +    (version "0.1.0")

Version is not exactly "0.1.0", so I used `git-version' with appropriate
version, revision, and commit. I also added a comment about it.

> +    (description
> +     "Tools for generating package-desc structures and feeding them to
> +package.el.")

I reworded the description so it would consist of a full sentence.

Regards,
Andrew Tropin Dec. 9, 2021, 11:20 a.m. UTC | #2
On 2021-12-09 09:15, Nicolas Goaziou wrote:

> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-dpd): New variable.
>
> Thank you. I applied your patch with the following changes:
>
>> +(define-public emacs-dpd
>> +  (package
>> +    (name "emacs-dpd")
>> +    (version "0.1.0")
>
> Version is not exactly "0.1.0", so I used `git-version' with appropriate
> version, revision, and commit. I also added a comment about it.
>
>> +    (description
>> +     "Tools for generating package-desc structures and feeding them to
>> +package.el.")
>
> I reworded the description so it would consist of a full sentence.
>
> Regards,

Thank you very much!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e542da0c26..05c193b4dc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21434,6 +21434,29 @@  (define-public emacs-packed
 package recipes.")
     (license license:gpl3+)))
 
+(define-public emacs-dpd
+  (package
+    (name "emacs-dpd")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/lilyp/emacs-dpd")
+             (commit "f53f251a58859f375617ce4f257fecc83c8ca5da")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1nislvaxjb53x2ah330szcca4d595npx6zxrrwa5xximj6365wk0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-packed" ,emacs-packed)))
+    (home-page "https://gitlab.com/lilyp/emacs-dpd")
+    (synopsis "Deliver packages to package.el")
+    (description
+     "Tools for generating package-desc structures and feeding them to
+package.el.")
+    (license license:gpl3+)))
+
 (define-public emacs-picpocket
   (let ((version "41")
         (commit "fa3a49f011b5ae139728548fec7375743f61c7c7"))