diff mbox series

[bug#64213,v2,2/2] gnu: imgui-1.86: Adjust make-flags.

Message ID 877cro8kr9.fsf@protonmail.com
State New
Headers show
Series [bug#64213] gnu: imgui-1.86: Fix build for mangohud. | expand

Commit Message

John Kehayias June 28, 2023, 12:59 a.m. UTC
Empty Message
diff mbox series

Patch

From 07f13208564e4a5ee5d5509f6abdd09f18414ce4 Mon Sep 17 00:00:00 2001
Message-Id: <07f13208564e4a5ee5d5509f6abdd09f18414ce4.1687913689.git.john.kehayias@protonmail.com>
In-Reply-To: <82f14241e45a4d56fdf26e7bc463407941ead4a7.1687913689.git.john.kehayias@protonmail.com>
References: <82f14241e45a4d56fdf26e7bc463407941ead4a7.1687913689.git.john.kehayias@protonmail.com>
From: John Kehayias <john.kehayias@protonmail.com>
Date: Tue, 27 Jun 2023 20:49:34 -0400
Subject: [PATCH 2/2] gnu: imgui-1.86: Adjust make-flags.

* gnu/packages/toolkits.scm (imgui-1.86)[arguments]: Remove the
"-DImDrawIdx=unsigned int" make-flag which breaks the display of mangohud, the
only dependent.
---
 gnu/packages/toolkits.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index 1af10d83f4..46b7fd2cd6 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -168,4 +168,10 @@  (define-public imgui-1.86
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "02a7b05zrka20jhzag2jb4jl624i1m456bsv69jb9zgys2p9dv1n"))))))
+                "02a7b05zrka20jhzag2jb4jl624i1m456bsv69jb9zgys2p9dv1n"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments imgui)
+       ((#:make-flags flags ''())
+        ;; Remove the "-DImDrawIdx=unsigned int" make-flag as this breaks
+        ;; mangohud, the only user of this version.
+        #~(delete "-DImDrawIdx=unsigned int" #$flags))))))
-- 
2.40.1