diff mbox series

bug#67183: [PATCH] gnu: Add python-canmatrix.

Message ID 877cm41720.fsf@gnu.org
State New
Headers show
Series bug#67183: [PATCH] gnu: Add python-canmatrix. | expand

Commit Message

Ludovic Courtès Nov. 26, 2023, 10:30 p.m. UTC
Hi,

Troy Figiel <troy@troyfigiel.com> skribis:

> * gnu/packages/python-xyz.scm (python-canmatrix): New variable.
>
> Change-Id: I96192f7304388aefe1b5cc358d462d42120ca3a0

Applied with the cosmetic changes below, following
<https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html>.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea1b56fa82..746ecccc5a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2981,12 +2981,13 @@  (define-public python-canmatrix
                              python-six))
     (native-inputs (list python-lxml python-pytest python-xlrd python-xlwt))
     (home-page "https://github.com/ebroecker/canmatrix")
-    (synopsis "Implements a CAN matrix object in Python")
+    (synopsis "@acronym{CAN, Controller Area Network} matrices in Python")
     (description
-     "This package implements a CAN matrix object in Python which describes the
-CAN-communication and its needed objects such as board units, frames, signals
-and values.  It also includes two command line tools (canconvert and
-cancompare) for converting and comparing CAN databases.")
+     "This package implements a @acronym{CAN, Controller Area Network} matrix
+object in Python which describes the CAN-communication and its needed objects
+such as board units, frames, signals, and values.  It also includes two
+command-line tools (@command{canconvert} and @command{cancompare}) for
+converting and comparing CAN databases.")
     (license license:bsd-2)))
 
 (define-public python-canopen