diff mbox series

[bug#68152] gnu: Add "go-github-com-google-btree" and "go-github-com-peterbourgon-diskv"

Message ID 877ckv1r60.fsf@gmail.com
State New
Headers show
Series [bug#68152] gnu: Add "go-github-com-google-btree" and "go-github-com-peterbourgon-diskv" | expand

Commit Message

Artyom V. Poptsov Dec. 30, 2023, 6:28 p.m. UTC
Hello,

this patch series adds "go-github-com-google-btree" and
"go-github-com-peterbourgon-diskv".
- avp

Comments

Sharlatan Hellseher Jan. 12, 2024, 10:31 p.m. UTC | #1
Hi

I've re-based patches from the latest master commit and resolved conflict. Lint
and build passed successfully.

[env: /gnu/store/vpzdg6vmqja1xdsdfs84jm9py4qmf6xf-profile]
> ./pre-inst-env guix build --rounds=2 go-github-com-peterbourgon-diskv go-github-com-google-btree
/gnu/store/kh1gcimdv45f44d6xh25dknn5lp4j2a9-go-github-com-google-btree-1.1.2
/gnu/store/3z4ccdw2jlz2blzqr9ibm07syh7wajhx-go-github-com-peterbourgon-diskv-3.0.0
[env: /gnu/store/vpzdg6vmqja1xdsdfs84jm9py4qmf6xf-profile]
> ./pre-inst-env guix lint go-github-com-peterbourgon-diskv go-github-com-google-btree
fetching CVE database for 2024...on-diskv@3.0.0 [cve]...
fetching CVE database for 2023...
fetching CVE database for 2022...
fetching CVE database for 2021...
gnu/packages/golang.scm:12059:13:
go-github-com-peterbourgon-diskv@3.0.0: can be upgraded to 3.0.1

This warning is irrelevant, and may be ignored:
gnu/packages/golang.scm:12059:13:
go-github-com-peterbourgon-diskv@3.0.0: can be upgraded to 3.0.1

Upstream has an issue with tagging and release:
latest tag: https://github.com/peterbourgon/diskv/tree/v3.0.1
latest release: https://github.com/peterbourgon/diskv/releases/tag/v3.0.0

If it's chunk of long patch series, please let me know which project are you
trying to pack, let's share efforts :-)

Pushed to master as 0edf8a2eabd386d209d4b32aca599ce22a3a7533
--
VCS: https://github.incerto.xyz/; https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
diff mbox series

Patch

From 7a80edcbdd789d80fd6065e97e79c710626e41c5 Mon Sep 17 00:00:00 2001
Message-ID: <7a80edcbdd789d80fd6065e97e79c710626e41c5.1703960709.git.poptsov.artyom@gmail.com>
In-Reply-To: <f6b9da71abd070f8c6a1a77374a4017b24b7f8d8.1703960709.git.poptsov.artyom@gmail.com>
References: <f6b9da71abd070f8c6a1a77374a4017b24b7f8d8.1703960709.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 30 Dec 2023 21:24:42 +0300
Subject: [PATCH 2/2] gnu: Add go-github-com-peterbourgon-diskv.

* gnu/packages/golang.scm (go-github-com-peterbourgon-diskv): New variable.

Change-Id: I0292404c636c42389c11c0ed552bacbf02178f7c
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4d8dee6d3c..81771b1788 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12954,6 +12954,33 @@  (define-public go-github-com-google-btree
 ordered, mutable data structure.")
     (license license:asl2.0)))
 
+(define-public go-github-com-peterbourgon-diskv
+  (package
+    (name "go-github-com-peterbourgon-diskv")
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/peterbourgon/diskv")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0pdy8f7bkm65gx4vknwcvfa619hknflqxkdlvmf427k2mzm91gmh"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/peterbourgon/diskv"
+       #:go ,go-1.18))
+    (propagated-inputs (list go-github-com-google-btree))
+    (home-page "https://github.com/peterbourgon/diskv")
+    (synopsis "Disk-backed key-value store")
+    (description
+     "Diskv (disk-vee) is a simple, persistent key-value store written in the Go
+language.  It starts with a simple API for storing arbitrary data on a filesystem by
+key, and builds several layers of performance-enhancing abstraction on top.  The end
+result is a conceptually simple, but highly performant, disk-backed storage system.")
+    (license license:expat)))
+
 (define-public go-github-com-gorilla-websocket
   (package
     (name "go-github-com-gorilla-websocket")
-- 
2.41.0