diff mbox series

[bug#68330] gnu: Add rust-cachedir-0.3.

Message ID 877ckjivxw.fsf@troyfigiel.com
State New
Headers show
Series [bug#68330] gnu: Add rust-cachedir-0.3. | expand

Commit Message

Troy Figiel Jan. 8, 2024, 5:18 p.m. UTC
* gnu/packages/crates-io.scm (rust-cachedir-0.3): New variable.
---
 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 5f8a993aa85554ca09bd27139230d7664107e1b6

Comments

Efraim Flashner Jan. 19, 2024, 9:38 a.m. UTC | #1
Thanks. I pushed this to the rust-team branch
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1bfd8fb143..ac0be483f5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11057,6 +11057,30 @@  (define-public rust-cache-padded-1
 cached data.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-cachedir-0.3
+  (package
+    (name "rust-cachedir")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "cachedir" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0wyqx30crm2qsq4ny57hhljyq6iw6j4qfg7fbfiqznvpf29z60s7"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/jstasiak/cachedir")
+    (synopsis "Interact with cache directories and @file{CACHEDIR.TAG} files")
+    (description
+     "This package provides a library to help interacting with cache
+directories and @file{CACHEDIR.TAG} files as defined by the Cache Directory
+Tagging Specification.  This library comes with functionality to, among
+others, add a tag, ensure/check a tag exists and get the state of a tag.")
+    (license license:expat)))
+
 (define-public rust-calamine-0.18
   (package
     (name "rust-calamine")