diff mbox series

[bug#68572] gnu: kubo: Update to 0.16.0.

Message ID 877ck6mn0h.fsf@gmail.com
State New
Headers show
Series [bug#68572] gnu: kubo: Update to 0.16.0. | expand

Commit Message

Artyom V. Poptsov Jan. 18, 2024, 7:58 p.m. UTC
Hello,

this patch updates Kubo (IPFS) to 0.16.0.
Thanks,
- avp

Comments

Sharlatan Hellseher Jan. 19, 2024, 10:55 p.m. UTC | #1
Hi,

I've done some analysis of the vendor directory, and it contains a
massive list of missed Guix packages. I see that version 0.16.0 is not
the latest upstream version for that reason.

A quick review of the required modules for the latest version of *kubo*,
v0.25.0, shows that it requires significant packaging efforts.
Hopefully, some of the missing ones will be covered after all pending
patches related to Golang are merged.

https://github.com/ipfs/kubo/blob/v0.25.0/go.mod

Keep this message here for future reference regarding the update of
*kubo*.

Quick rough script to check missing packages
--8<---------------cut here---------------start------------->8---
cd vendor
find * -maxdepth 2 -mindepth 2 -type d |
    sed -e 's/[\.\/]/-/g' |
    sort |
    while read -r m
    do
        echo "go-$m"
    done |
    while read -r p
    do
        guix show $p 2>&1
    done |
    grep "package not found" |
    tee kubo-vendor-package-not-found
--8<---------------cut here---------------start------------->8---

Pushed as
diff mbox series

Patch

From 3f92e0020f9cc94ae342f5f85ed138ff51480616 Mon Sep 17 00:00:00 2001
Message-ID: <3f92e0020f9cc94ae342f5f85ed138ff51480616.1705607838.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Thu, 18 Jan 2024 22:57:03 +0300
Subject: [PATCH] gnu: kubo: Update to 0.16.0.

* gnu/packages/ipfs.scm (kubo): Update to 0.16.0.
  [arguments]: Use go-1.18.
  [home-page]: Set to "https://ipfs.tech".

Change-Id: I06239354b0c9c23294d5aeac6d01f67636d5d3a5
---
 gnu/packages/ipfs.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index fc66582c8a..0c8c6ed820 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -4,7 +4,7 @@ 
 ;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
 ;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
-;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -223,7 +223,7 @@  (define-public gx-go
 (define-public kubo
   (package
     (name "kubo")
-    (version "0.15.0")
+    (version "0.16.0")
     (source
      (origin
        (method url-fetch/tarbomb)
@@ -231,7 +231,7 @@  (define-public kubo
              "https://dist.ipfs.io/kubo/v" version
              "/kubo-source.tar.gz"))
        (sha256
-        (base32 "0ss5k8xnzn9qk977dni5ja89yygcysdw7r3mdk67cac2dpa9hhqs"))
+        (base32 "0v8p4mjwsrqxzd6wdzafxnnfrv919x5p3r5342lbrjdv0k0yabhm"))
        (file-name (string-append name "-" version "-source"))
        (modules '((guix build utils)))
        (snippet '(for-each delete-file-recursively
@@ -286,6 +286,7 @@  (define-public kubo
      (list
       #:unpack-path "github.com/ipfs/kubo"
       #:import-path "github.com/ipfs/kubo/cmd/ipfs"
+      #:go go-1.18
       #:phases
       #~(modify-phases %standard-phases
           ;; https://github.com/ipfs/kubo/blob/master/docs/command-completion.md
@@ -361,7 +362,7 @@  (define-public kubo
                  (list this-package)
                  '())
              (list python-minimal-wrapper zsh)))
-    (home-page "https://ipfs.io")
+    (home-page "https://ipfs.tech")
     (synopsis "Go implementation of IPFS, a peer-to-peer hypermedia protocol")
     (description "IPFS is a global, versioned, peer-to-peer file system.  It
 combines good ideas from Git, BitTorrent, Kademlia, SFS, and the Web.  It is

base-commit: 3e3975275bbab84d58f7740e9680b265769aa580
-- 
2.41.0