From f93366cb785f4783efe3c5e4027ae2062f0f87a3 Mon Sep 17 00:00:00 2001
From: Benjamin Slade <slade@lambda-y.net>
Date: Mon, 18 Mar 2024 17:47:03 -0500
Subject: [PATCH] gnu: Add python-x-wr-timezone.
* gnu/packages/<module>.scm (python-x-wr-timezone): New variable
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
@@ -149,6 +149,7 @@
;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
;;; Copyright © 2024 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
+;;; Copyright © 2024 Benjamin Slade <slade@lambda-y.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17622,6 +17623,33 @@ (define-public python-execnet
(home-page "https://codespeak.net/execnet/")
(license license:expat))))
+(define-public python-x-wr-timezone
+ (package
+ (name "python-x-wr-timezone")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "x_wr_timezone" version))
+ (sha256
+ (base32 "0j5zjvrshn7smq6cgbh7l66dl64wqs18cfyfnq1np1y00g320pha"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Broken tests or cyclic dependecies with other packages.
+ '(#:phases (modify-phases %standard-phases
+ (delete 'sanity-check))
+ #:tests? #f))
+ (propagated-inputs (list python-icalendar python-pytz))
+ (home-page "https://github.com/niccokunzmann/x-wr-timezone")
+ (synopsis "Handling of non-standard X-WR-TIMEZONE icalendar property")
+ (description
+ "Some calendar providers introduce the non-standard X-WR-TIMEZONE
+parameter to ICS calendar files. Strict interpretations according to RFC 5545 ignore
+ the X-WR-TIMEZONE parameter. This causes the times of the events to differ from those
+ which make use of X-WR-TIMEZONE. This module aims to bridge the gap by converting
+ calendars using X-WR-TIMEZONE to a strict RFC 5545 calendars.")
+ (license license:lgpl3+)))
+
(define-public python-icalendar
(package
(name "python-icalendar")
--
2.41.0