diff mbox series

[bug#71701] : Update sbcl-fset to 1.4.0

Message ID 877cei7aeh.fsf@gmail.com
State New
Headers show
Series [bug#71701] : Update sbcl-fset to 1.4.0 | expand

Commit Message

André A. Gomes June 21, 2024, 12:22 p.m. UTC
Attached, thanks.

Comments

jgart June 21, 2024, 9:29 p.m. UTC | #1
Hi André,

Thanks for the patch.

When I try to apply your patch I get the below error.

Would you mind sharing how you sent the patch so I can debug this issue a bit.

Did you use git send-email or something else?

Thanks!

jgart


jgart@unknown1ee35e825799:~/Code/guix-latest [env]$ mumi am -- -s -S
Patch is empty.
hint: When you have resolved this problem, run "git am --continue".
hint: If you prefer to skip this patch, run "git am --skip" instead.
hint: To record the empty patch as an empty commit, run "git am --allow-empty".
hint: To restore the original branch and stop patching, run "git am --abort".
hint: Disable this message with "git config advice.mergeConflict false"
Backtrace:
           2 (primitive-load "/gnu/store/p3xfvin2a76618144l39i4nn17a…")
In srfi/srfi-1.scm:
    634:9  1 (for-each #<procedure 7fd6f46c69c0 at mumi/client.scm:…> …)
In mumi/client.scm:
   249:12  0 (call-with-output-pipe* _ _ . _)

mumi/client.scm:249:12: In procedure call-with-output-pipe*:
Command invocation failed failed ("git" "am" "-s" "-S")
André A. Gomes June 25, 2024, 10:19 a.m. UTC | #2
"jgart" <jgart@dismail.de> writes:

> When I try to apply your patch I get the below error.
>
> Would you mind sharing how you sent the patch so I can debug this issue a bit.
>
> Did you use git send-email or something else?

Hi jgart,

I sent the patch as an email attachment.  I am not very comfortable
doing it via git send-email but can look into it if it's a hard
requirement.

Usually Guillaume tests my patches since I mainly contribute to the lisp
effort, and it has been working for him.

Thanks.
jgart June 25, 2024, 4:35 p.m. UTC | #3
> I sent the patch as an email attachment. I am not very comfortable
> 
> doing it via git send-email but can look into it if it's a hard requirement.

It's currently not a hard requirement but it makes my job harder for my workflow of using the `mumi am` tool to apply patches.

I'll let Guillaume review this one if Guillaume is able to. It would be much appreciated.

In the meantime, I'll try to work on getting `mumi am` to accept and support email-sent patches if I am going to review patches like this one in the future that don't apply via `mumi am`.

Thanks for the report and for your contribution.

all the best,

jgart
Guillaume Le Vaillant June 26, 2024, 9:09 a.m. UTC | #4
Patch applied as c32b31ecfcb7e6c51bfe457cce70d7b6b36b9cca with
a completed commit message.
Thanks.
diff mbox series

Patch

From a2af63010b5d3063b0a94678f0ef2b9c82a988b4 Mon Sep 17 00:00:00 2001
From: "Andre A. Gomes" <andremegafone@gmail.com>
Date: Fri, 21 Jun 2024 15:22:12 +0300
Subject: [PATCH] gnu: sbcl-fset: Update to 1.4.0.

* gnu/packages/lisp-xyz.scm (sbcl-fset): Update to 1.4.0.
---
 gnu/packages/lisp-xyz.scm | 54 +++++++++++++++------------------------
 1 file changed, 20 insertions(+), 34 deletions(-)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2a1687be40..58df036241 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15654,44 +15654,30 @@  (define-public ecl-formgrep
   (sbcl-package->ecl-package sbcl-formgrep))
 
 (define-public sbcl-fset
-  (let ((commit "a75a4ec713277780d9e15bfaa486b56949142d35")
-        (revision "1"))
-    (package
-      (name "sbcl-fset")
-      (version (git-version "1.3.3" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/slburson/fset")
-               (commit commit)))
-         (file-name (git-file-name "cl-fset" version))
-         (sha256
-          (base32 "0bah0z8zrcykvnbi2wcdlbx902r818xg5dvd3384wf75kr2ccxvv"))
-         (snippet '(begin
-                     ;; Remove obsolete copy of system definition.
-                     (delete-file "Code/fset.asd")))))
-      (build-system asdf-build-system/sbcl)
-      (inputs
-       (list sbcl-misc-extensions sbcl-mt19937 sbcl-named-readtables))
-      (arguments
-       (list #:phases
-             #~(modify-phases %standard-phases
-                 (add-after 'unpack 'fix-build
-                   (lambda _
-                     ;; Fix for SBCL > 2.4.4
-                     (substitute* "Code/port.lisp"
-                       (("sb-ext::once-only")
-                        "sb-int:once-only")))))))
-      (synopsis "Functional set-theoretic collections library")
-      (description
-       "FSet is a functional set-theoretic collections library for Common Lisp.
+  (package
+    (name "sbcl-fset")
+    (version "1.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/slburson/fset")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name "cl-fset" version))
+       (sha256
+        (base32 "16a3g9av8rvhvnhv5vfq2shim7b7i062wzyz6xwjk9sp9q9bqlva"))))
+    (build-system asdf-build-system/sbcl)
+    (inputs
+     (list sbcl-misc-extensions sbcl-mt19937 sbcl-named-readtables))
+    (synopsis "Functional set-theoretic collections library")
+    (description
+     "FSet is a functional set-theoretic collections library for Common Lisp.
 Functional means that all update operations return a new collection rather than
 modifying an existing one in place.  Set-theoretic means that collections may
 be nested arbitrarily with no additional programmer effort; for instance, sets
 may contain sets, maps may be keyed by sets, etc.")
-      (home-page "https://common-lisp.net/project/fset/Site/index.html")
-      (license license:llgpl))))
+    (home-page "https://common-lisp.net/project/fset/Site/index.html")
+    (license license:llgpl)))
 
 (define-public cl-fset
   (sbcl-package->cl-source-package sbcl-fset))
-- 
2.41.0