[bug#74329,v3,6/8] gnu: Replace quotations with texinfo markup in Rust packages.

Message ID 877c78qlbb.fsf@erlikon.ch
State New
Headers
Series None |

Commit Message

Gabriel Wicki Jan. 6, 2025, 10:20 a.m. UTC
  * gnu/packages/crates-graphics.scm (rust-avif-serialize-0.8): Fix description.
* gnu/packages/crates-io.scm (rust-async-process-2, rust-stringprep-0.1): Fix
description.
* gnu/packages/crates-web.scm (rust-hickory-recursor-0.24): Fix description.

Change-Id: I4050a893b3f0f930863cbf5b63e699cdcd60d498
---
 gnu/packages/crates-graphics.scm | 4 ++--
 gnu/packages/crates-io.scm       | 6 +++---
 gnu/packages/crates-web.scm      | 2 +-
 3 files changed, 6 insertions(+), 6 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 9d7f44693a..0b26cd5419 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -484,8 +484,8 @@  (define-public rust-avif-serialize-0.8
     (description
      "This package provides a minimal writer for AVIF header structure.  This
 is a tiny alternative to @code{libavif}.  It creates the jungle of
-MPEG/HEIF/MIAF/ISO-BMFF ``boxes'' as appropriate for AVIF files.  It supports
-alpha channel embedding.")
+MPEG/HEIF/MIAF/ISO-BMFF @emph{boxes} as appropriate for AVIF files.  It
+supports alpha channel embedding.")
     (license license:bsd-3)))
 
 (define-public rust-avif-serialize-0.7
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7716a24dc3..5c818807f1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5711,7 +5711,7 @@  (define-public rust-async-process-2
      "This crate is an async version of @code{std::process}.  A background
 thread named @code{async-process} is lazily created on first use, which waits
 for spawned child processes to exit and then calls the @code{wait()} syscall
-to clean up the ``zombie'' processes.
+to clean up the @emph{zombie} processes.
 
 This is unlike the process API in the standard library, where dropping
 a running Child leaks its resources.")
@@ -78668,8 +78668,8 @@  (define-public rust-stringprep-0.1
     (home-page "https://github.com/sfackler/rust-stringprep")
     (synopsis "Implementation of the ``stringprep'' algorithm")
     (description
-     "This package provides an implementation of the ``stringprep'' algorithm
-as defined in RFC 3454.")
+     "This package provides an implementation of the @code{stringprep}
+algorithm as defined in RFC 3454.")
     (license (list license:expat license:asl2.0))))
 
 (define-public rust-strip-ansi-escapes-0.2
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index f2fadfdeba..e04eaa32a3 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2956,7 +2956,7 @@  (define-public rust-hickory-recursor-0.24
     (synopsis
      "Hickory DNS Recursor is a DNS recursive resolver with DNSSEC support")
     (description
-     "*WARNING* This library is experimental
+     "@emph{WARNING} This library is experimental
 
 Hickory DNS Recursor is a safe and secure DNS recursive resolver with DNSSEC
 support.  Hickory DNS is based on the Tokio and Futures libraries, which means