[bug#77270] Add rivercarro package
Commit Message
This package adds rivercarro package.
--
- Apoorv Singh
- Sent from Emacs.
From 492c2d08d9f10c7db2685923d1153c1f275979bd Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Wed, 26 Mar 2025 11:29:58 +0530
Subject: [PATCH] Add rivercarro package
Change-Id: I2ae4ec4a69103837cefb468222ab859241d98fc2
---
gnu/packages/zig-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)
@@ -146,6 +146,46 @@ (define-public river
directly from a tty using KMS/DRM.")
(license license:gpl3)))
+(define-public rivercarro
+ (let ((commit "2c83990c80fab29e942b783d7194b5cab13f745a")
+ (revision "0"))
+ (package
+ (name "rivercarro")
+ (version (git-version "0.6.0-dev" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~novakane/rivercarro")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dhwxpxl73r3hvgb7sw3f75ybg9n0lanvbc921k42vkk4gxklnmb"))))
+ (build-system zig-build-system)
+ (arguments
+ (list #:tests? #f
+ #:install-source? #f
+ #:zig-release-type "safe"))
+ (inputs (list zig-wayland))
+ (native-inputs (list pkg-config))
+ (home-page "https://git.sr.ht/~novakane/rivercarro")
+ (synopsis "A slightly modified version of rivertile layout generator for river.")
+ (description "A slightly modified version of rivertile layout generator for river.
+
+Compared to rivertile, rivercarro adds:
+
+@enumerate
+@item Monocle layout, views will takes all the usable area on the screen.
+@item Gaps instead of padding around views or layout area.
+@item Modify gaps size at runtime.
+@item Smart gaps, if there is only one view, gaps will be disable.
+@item Limit the width of the usable area of the screen.
+@item Per tag configurations.
+@item Cycle through layout
+@end enumerate
+")
+ (license license:gpl3))))
+
(define-public tigerbeetle
(package
(name "tigerbeetle")
--
2.49.0