[bug#34171,5/5] gnu: Add ocaml-craml.

Message ID 875zufzvn9.fsf@gmail.com
State Accepted
Headers show
Series [bug#34171,1/5] gnu: ocaml-uchar: Update to 0.0.2. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Jan. 23, 2019, 7:21 a.m. UTC
Date: Tue, 22 Jan 2019 17:40:01 +0100
User-agent: mu4e 1.0; emacs 26.1
+@code{https://bitheap.org/cram/, Python tool}, which was itself based on
* gnu/packages/ocaml.scm (ocaml-craml): New variable.
---
 gnu/packages/ocaml.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Julien Lepiller Jan. 23, 2019, 7:54 a.m. UTC | #1
Le 23 janvier 2019 08:21:46 GMT+01:00, Gabriel Hondet <gabrielhondet@gmail.com> a écrit :
>Date: Tue, 22 Jan 2019 17:40:01 +0100
>User-agent: mu4e 1.0; emacs 26.1
>+@code{https://bitheap.org/cram/, Python tool}, which was itself based
>on
>* gnu/packages/ocaml.scm (ocaml-craml): New variable.
>---
> gnu/packages/ocaml.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
>
>diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
>index ca8f804ab..4c3aa36b0 100644
>--- a/gnu/packages/ocaml.scm
>+++ b/gnu/packages/ocaml.scm
>@@ -4760,6 +4760,36 @@ yojson package.  The program @code{atdgen} can
>be used to derive OCaml-JSON
> serializers and deserializers from type definitions.")
>     (license license:bsd-3)))
> 
>+(define-public ocaml-craml
>+  (package
>+    (name "ocaml-craml")
>+    (version "1.0.0")
>+    (home-page "https://github.com/realworldocaml/craml")
>+    (source
>+     (origin
>+       (method git-fetch)
>+       (uri (git-reference
>+             (url (string-append home-page ".git"))
>+             (commit version)))
>+       (file-name (git-file-name name version))
>+       (sha256
>+        (base32
>+         "197xjp4vmzdymf2ndinw271ihpf45h04mx8gqj8ypspxdr5fj1a5"))))
>+    (build-system dune-build-system)
>+    (inputs
>+     `(("ocaml-fmt" ,ocaml-fmt)
>+       ("ocaml-astring" ,ocaml-astring)
>+       ("ocaml-logs" ,ocaml-logs)
>+       ("ocaml-cmdliner" ,ocaml-cmdliner)))
>+    (synopsis
>+     "CRAM-testing framework for testing command line applications")
>+    (description "CRAM is a is functional testing framework for
>command line
>+applications.  @code{craml} is freely inspired by the
>+Mercurial's @code{https://www.selenic.com/blog/?p=663, unified test
>+format}.  @code{craml} is released as a single binary (called
>@code{craml}).")
>+    (license license:isc)))
>+
> (define-public ocaml-merlin
>   (package
>     (name "ocaml-merlin")

Hi, thanks for these patches! They lgtm, but please be careful with the headers: there's something strange in the commit message of this and other patches.

I'll check them properly and push later today. Thanks!
Gabriel Hondet Jan. 23, 2019, 8:15 a.m. UTC | #2
Hi,

On Wed 23 Jan 2019 at 08:54 Julien Lepiller wrote:

>> Date: Tue, 22 Jan 2019
>> User-agent: mu4e 1.0;
>> [...]
>
> Hi, thanks for these patches! They lgtm, but please be careful with
> the headers: there's something strange in the commit message of this
> and other patches.

Ah, indeed, some commit message contain some email headers... sorry.

> I'll check them properly and push later today. Thanks!

Great, thanks!
Gabriel

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ca8f804ab..4c3aa36b0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4760,6 +4760,36 @@  yojson package.  The program @code{atdgen} can be used to derive OCaml-JSON
 serializers and deserializers from type definitions.")
     (license license:bsd-3)))
 
+(define-public ocaml-craml
+  (package
+    (name "ocaml-craml")
+    (version "1.0.0")
+    (home-page "https://github.com/realworldocaml/craml")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url (string-append home-page ".git"))
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "197xjp4vmzdymf2ndinw271ihpf45h04mx8gqj8ypspxdr5fj1a5"))))
+    (build-system dune-build-system)
+    (inputs
+     `(("ocaml-fmt" ,ocaml-fmt)
+       ("ocaml-astring" ,ocaml-astring)
+       ("ocaml-logs" ,ocaml-logs)
+       ("ocaml-cmdliner" ,ocaml-cmdliner)))
+    (synopsis
+     "CRAM-testing framework for testing command line applications")
+    (description "CRAM is a is functional testing framework for command line
+applications.  @code{craml} is freely inspired by the
+Mercurial's @code{https://www.selenic.com/blog/?p=663, unified test
+format}.  @code{craml} is released as a single binary (called @code{craml}).")
+    (license license:isc)))
+
 (define-public ocaml-merlin
   (package
     (name "ocaml-merlin")
-- 
2.20.1