[bug#34415] gnu: Add ghc-alsa-core.

Message ID 875ztr4lvi.fsf@gmail.com
State Accepted
Commit 3fc88ff0f3499b9be2eb8177084752feb2e2508f
Headers show
Series [bug#34415] gnu: Add ghc-alsa-core. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Feb. 10, 2019, 3:39 p.m. UTC
* gnu/packages/haskell.scm (ghc-alsa-core): New variable.
---
 gnu/packages/haskell.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Danny Milosavljevic Feb. 10, 2019, 8:38 p.m. UTC | #1
Thanks!  Pushed to guix master as 3fc88ff0f3499b9be2eb8177084752feb2e2508f.

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 255e902e6..eecb5b71c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11493,4 +11493,29 @@  imported with the correct Haskell types.")
 Music Player Daemon.")
     (license license:expat)))
 
+(define-public ghc-alsa-core
+  (package
+    (name "ghc-alsa-core")
+    (version "0.5.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://hackage/package/alsa-core/alsa-core-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1avh4a419h9d2zsslg6j8hm87ppgsgqafz8ll037rk2yy1g4jl7b"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+       ("alsa-lib" ,alsa-lib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.haskell.org/haskellwiki/ALSA")
+    (synopsis "Binding to the ALSA Library API (Exceptions)")
+    (description "This package provides access to ALSA infrastructure, that is
+needed by both alsa-seq and alsa-pcm.")
+    (license license:bsd-3)))
 ;;; haskell.scm ends here