[bug#34538] gnu: Add r-sloop.

Message ID 875ztg8zas.fsf@posteo.net
State Accepted
Headers show
Series [bug#34538] gnu: Add r-sloop. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brett Gilio Feb. 18, 2019, 11:14 p.m. UTC

Comments

Ricardo Wurmus Feb. 20, 2019, 4:47 p.m. UTC | #1
Hi Brett,

> * gnu/packages/cran.scm (r-sloop): New variable.
[…]
> +
> +(define-public r-sloop
> +  (package
> +  (name "r-sloop")
> +  (version "1.0.1")
> +  (source
> +    (origin
> +      (method url-fetch)
> +      (uri (cran-uri "sloop" version))
> +      (sha256
> +        (base32
> +          "00fk5fr5zsk2qxc1kfhmshhjxgnamm3401089sx8m2l529zd6r8j"))))
> +  (build-system r-build-system)
> +  (propagated-inputs
> +    `(("r-codetools" ,r-codetools)
> +      ("r-crayon" ,r-crayon)
> +      ("r-purrr" ,r-purrr)
> +      ("r-rlang" ,r-rlang)
> +      ("r-tibble" ,r-tibble)))
> +  (home-page "https://github.com/r-lib/sloop")
> +  (synopsis "Helpers for 'OOP' in R")
> +  (description
> +    "This package provides a collection of helper functions designed to help you to better understand object oriented programming in R, particularly using 'S3'.")
> +  (license license:gpl3)))

There are a couple of problems here:

- The indentation is wrong throughout.
- Please don’t use “'” in the synopsis and description.
- Please spell out “OOP” in the synopsis
- Please break the long description up into several lines.  “guix lint”
  will warn you about this, so please use it.

Could you please send a new patch to 34538@debbugs.gnu.org?

Thanks!

--
Ricardo
Brett Gilio Feb. 20, 2019, 6:49 p.m. UTC | #2
Ricardo Wurmus writes:

> Hi Brett,
>
>> * gnu/packages/cran.scm (r-sloop): New variable.
> […]
>> +
>> +(define-public r-sloop
>> +  (package
>> +  (name "r-sloop")
>> +  (version "1.0.1")
>> +  (source
>> +    (origin
>> +      (method url-fetch)
>> +      (uri (cran-uri "sloop" version))
>> +      (sha256
>> +        (base32
>> +          "00fk5fr5zsk2qxc1kfhmshhjxgnamm3401089sx8m2l529zd6r8j"))))
>> +  (build-system r-build-system)
>> +  (propagated-inputs
>> +    `(("r-codetools" ,r-codetools)
>> +      ("r-crayon" ,r-crayon)
>> +      ("r-purrr" ,r-purrr)
>> +      ("r-rlang" ,r-rlang)
>> +      ("r-tibble" ,r-tibble)))
>> +  (home-page "https://github.com/r-lib/sloop")
>> +  (synopsis "Helpers for 'OOP' in R")
>> +  (description
>> +    "This package provides a collection of helper functions designed to help you to better understand object oriented programming in R, particularly using 'S3'.")
>> +  (license license:gpl3)))
>
> There are a couple of problems here:
>
> - The indentation is wrong throughout.
> - Please don’t use “'” in the synopsis and description.
> - Please spell out “OOP” in the synopsis
> - Please break the long description up into several lines.  “guix lint”
>   will warn you about this, so please use it.
>
> Could you please send a new patch to 34538@debbugs.gnu.org?
>
> Thanks!

Hi Ricardo,

Yes. I must have missed linting this one, my apologies. Stand-by for a
new patch.

Patch

From 4354879abedcb0b127c726d175900de91c4fa5cc Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 18 Feb 2019 17:13:37 -0600
Subject: [PATCH] gnu: Add r-sloop.

* gnu/packages/cran.scm (r-sloop): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82fd465d7..75ed4f603 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10650,3 +10650,27 @@  analysis (@code{rrpca}), randomized interpolative decomposition (@code{rid}),
 and the randomized CUR decomposition (@code{rcur}).  In addition several plot
 functions are provided.")
     (license license:gpl3+)))
+
+(define-public r-sloop
+  (package
+  (name "r-sloop")
+  (version "1.0.1")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (cran-uri "sloop" version))
+      (sha256
+        (base32
+          "00fk5fr5zsk2qxc1kfhmshhjxgnamm3401089sx8m2l529zd6r8j"))))
+  (build-system r-build-system)
+  (propagated-inputs
+    `(("r-codetools" ,r-codetools)
+      ("r-crayon" ,r-crayon)
+      ("r-purrr" ,r-purrr)
+      ("r-rlang" ,r-rlang)
+      ("r-tibble" ,r-tibble)))
+  (home-page "https://github.com/r-lib/sloop")
+  (synopsis "Helpers for 'OOP' in R")
+  (description
+    "This package provides a collection of helper functions designed to help you to better understand object oriented programming in R, particularly using 'S3'.")
+  (license license:gpl3)))
-- 
2.20.1