[bug#34864,2/2] gnu: python-language-server: [propagated-inputs] add

Message ID 875zslxcyq.fsf@posteo.net
State Accepted
Headers show
Series [bug#34864,1/2] gnu: python-language-server: Update to 0.25.0. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Brett Gilio March 14, 2019, 11:17 p.m. UTC

Comments

Leo Famulari March 15, 2019, 1:43 a.m. UTC | #1
On Thu, Mar 14, 2019 at 06:17:49PM -0500, Brett Gilio wrote:
> From 844149bd57e7da174afb599dde2c5dca403ad8e7 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Thu, 14 Mar 2019 18:15:23 -0500
> Subject: [PATCH 2/2] gnu: python-language-server: [propagated-inputs] add
>  python-pylint.
> 
> * gnu/packages/python-xyz.scm (python-language-server): [propagated-inputs]
>   add python-pylint

Thanks!

I noticed that python-language-server 0.25.0 fails to build without this
change, so I squashed the commits into one and pushed as
fe4a4bd23aa55bc6e8f5639db0dbfb358df99861.

In general, if some changes need to happen in the same commit to avoid
breakage, we make them in the same commit.

Patch

From 844149bd57e7da174afb599dde2c5dca403ad8e7 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 14 Mar 2019 18:15:23 -0500
Subject: [PATCH 2/2] gnu: python-language-server: [propagated-inputs] add
 python-pylint.

* gnu/packages/python-xyz.scm (python-language-server): [propagated-inputs]
  add python-pylint
---
 gnu/packages/python-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f55b36bbd..706524bbb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2653,7 +2653,8 @@  Server (PLS).")
        ("python-pycodestyle" ,python-pycodestyle)
        ("python-mccabe" ,python-mccabe)
        ("python-rope" ,python-rope)
-       ("python-autopep8" ,python-autopep8)))
+       ("python-autopep8" ,python-autopep8)
+       ("python-pylint" ,python-pylint)))
     (home-page "https://github.com/palantir/python-language-server")
     (synopsis "Python implementation of the Language Server Protocol")
     (description
-- 
2.21.0