[bug#34906] gnu: Add go-github-com-burntsushi-locker

Message ID 875zsgt8qn.fsf@roquette.mug.biscuolo.net
State Accepted
Headers show
Series [bug#34906] gnu: Add go-github-com-burntsushi-locker | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Giovanni Biscuolo March 18, 2019, 5:04 p.m. UTC
Hi Guix!

I've packaged go-github-com-burntsushi-locker, it builds on my platform
and it's linted
Thanks!
Gio

Comments

Leo Famulari March 18, 2019, 5:24 p.m. UTC | #1
On Mon, Mar 18, 2019 at 06:04:00PM +0100, Giovanni Biscuolo wrote:
> Subject: [PATCH] gnu: Add go-github-com-burntsushi-locker
> 
> * gnu/packages/golang.scm (go-github-com-burntsushi-locker): New variable.

Thanks!

> +      (license license:public-domain))))

I changed this to 'unlicense' and pushed as
4ddf067f214b83c2ab03ed52a7e9ddf6f4f6de66

Patch

From 3601eec98d105cb657b80a0b0ba23c6cfc2fff41 Mon Sep 17 00:00:00 2001
From: Giovanni Biscuolo <g@xelera.eu>
Date: Mon, 18 Mar 2019 17:46:05 +0100
Subject: [PATCH] gnu: Add go-github-com-burntsushi-locker

* gnu/packages/golang.scm (go-github-com-burntsushi-locker): New variable.
---
 gnu/packages/golang.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4bcd5cfcfe..d7b7ea3fef 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright @ 2018 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3177,3 +3178,37 @@  format in Go.")
     (description "This package provides a text formatting functions in Go.")
     (home-page "https://github.com/kr/text")
     (license license:expat)))
+
+(define-public go-github-com-burntsushi-locker
+  (let ((commit "a6e239ea1c69bff1cfdb20c4b73dadf52f784b6a")
+        (revision "0"))
+    (package
+      (name "go-github-com-burntsushi-locker")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/BurntSushi/locker")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1xak4aync4klswq5217qvw191asgla51jr42y94vp109lirm5dzg"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/BurntSushi/locker"))
+      (home-page "https://github.com/BurntSushi/locker")
+      (synopsis "Manage named ReadWrite mutexes in Go")
+      (description "Golang package for conveniently using named read/write
+locks.  These appear to be especially useful for synchronizing access to
+session based information in web applications.
+
+The common use case is to use the package level functions, which use a package
+level set of locks (safe to use from multiple goroutines
+simultaneously).  However, you may also create a new separate set of locks
+test.
+
+All locks are implemented with read-write mutexes.  To use them like a regular
+mutex, simply ignore the RLock/RUnlock functions.")
+      (license license:public-domain))))
-- 
2.11.0