diff mbox series

[bug#36016] gnu: Add emacs-reformatter.

Message ID 875zprelxq.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#36016] gnu: Add emacs-reformatter. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

LaFreniere, Joseph May 30, 2019, 8:17 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-reformatter): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
--
Joseph LaFreniere

Comments

Ricardo Wurmus May 31, 2019, 8:17 a.m. UTC | #1
Hi Joseph,

> * gnu/packages/emacs-xyz.scm (emacs-reformatter): New variable.

Thanks!  I pushed this to the master branch with commit 8ae48674ce.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6f74a2fc45..bdb2d678cb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -804,6 +804,29 @@  skip set strings, which are arguments to @code{skip-chars-forward} and
 @code{skip-chars-backward}.")
     (license license:gpl3+)))
 
+(define-public emacs-reformatter
+  (package
+    (name "emacs-reformatter")
+    (version "0.4")
+    (source
+     (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/purcell/reformatter.el.git")
+            (commit version)))
+      (file-name (git-file-name name version))
+      (sha256
+       (base32
+        "0hhy6x1bkwlhdlarsgm06g3am4yh02yqv8qs34szpzgy53x84qah"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/purcell/reformatter.el")
+    (synopsis "Define commands which run reformatters on the current buffer")
+    (description
+     "This library lets elisp authors easily define an idiomatic command to
+reformat the current buffer using a command-line program, together with an
+optional minor mode which can apply this command automatically on save.")
+    (license license:gpl3+)))
+
 (define-public emacs-relint
   (package
     (name "emacs-relint")